Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 new Supermicro servers (5037C-T) with Ubuntu 12.10 and when I try to reboot the machine I instead get a nice shutdown.

Interestingly enough, the reboot command in the BIOS or grub work perfectly. Why would the Linux kernel get it wrong? Any idea how I could get that resolved? (It is annoying when I'm not next to the computer and need to reboot it... if you see what I mean.)

------------- update: contents of /etc/rc{0,6}.d

/etc/rc0.d:
lrwxrwxrwx 1 root root  29 Dec  1 22:50 K10unattended-upgrades -> ../init.d/unattended-upgrades
lrwxrwxrwx 1 root root  13 Dec 27 00:07 K20gpm -> ../init.d/gpm
lrwxrwxrwx 1 root root  20 Dec  1 23:52 K20kerneloops -> ../init.d/kerneloops
lrwxrwxrwx 1 root root  27 Dec  1 23:53 K20speech-dispatcher -> ../init.d/speech-dispatcher
lrwxrwxrwx 1 root root  20 Dec  2 22:21 K20virtualbox -> ../init.d/virtualbox
-rw-r--r-- 1 root root 353 Jul 20 19:42 README
lrwxrwxrwx 1 root root  18 Dec  1 22:41 S20sendsigs -> ../init.d/sendsigs
lrwxrwxrwx 1 root root  17 Dec  1 22:41 S30urandom -> ../init.d/urandom
lrwxrwxrwx 1 root root  22 Dec  1 22:41 S31umountnfs.sh -> ../init.d/umountnfs.sh
lrwxrwxrwx 1 root root  18 Dec  1 22:41 S40umountfs -> ../init.d/umountfs
lrwxrwxrwx 1 root root  20 Dec  1 22:41 S60umountroot -> ../init.d/umountroot
lrwxrwxrwx 1 root root  14 Dec  1 22:41 S90halt -> ../init.d/halt

/etc/rc6.d:
lrwxrwxrwx 1 root root  29 Dec  1 22:50 K10unattended-upgrades -> ../init.d/unattended-upgrades
lrwxrwxrwx 1 root root  13 Dec 27 00:07 K20gpm -> ../init.d/gpm
lrwxrwxrwx 1 root root  20 Dec  1 23:52 K20kerneloops -> ../init.d/kerneloops
lrwxrwxrwx 1 root root  27 Dec  1 23:53 K20speech-dispatcher -> ../init.d/speech-dispatcher
lrwxrwxrwx 1 root root  20 Dec  2 22:21 K20virtualbox -> ../init.d/virtualbox
-rw-r--r-- 1 root root 351 Jul 20 19:42 README
lrwxrwxrwx 1 root root  18 Dec  1 22:41 S20sendsigs -> ../init.d/sendsigs
lrwxrwxrwx 1 root root  17 Dec  1 22:41 S30urandom -> ../init.d/urandom
lrwxrwxrwx 1 root root  22 Dec  1 22:41 S31umountnfs.sh -> ../init.d/umountnfs.sh
lrwxrwxrwx 1 root root  18 Dec  1 22:41 S40umountfs -> ../init.d/umountfs
lrwxrwxrwx 1 root root  20 Dec  1 22:41 S60umountroot -> ../init.d/umountroot
lrwxrwxrwx 1 root root  16 Dec  1 22:41 S90reboot -> ../init.d/reboot

Update: For reference I wanted to add this link to the magic SysRq key information for Linux: http://en.wikipedia.org/wiki/Magic_SysRq_key

share|improve this question
    
When you were next to the server, did you try many ways to reboot it (shutdown -r now, alt sysreq sub, booting without acpi)? –  befree42 Dec 27 '12 at 9:53
1  
init 6 or shutdown -r now are the same thing. alt sysreq sub? How do your turn off acpi in grub command line terms? I'm also wondering what else could turning off acpi affect? If mainly nothing (I don't need suspend support at all, for example) then I'd be totally fine with it. –  Alexis Wilke Dec 27 '12 at 11:31
    
can you please paste your /etc/rc0.d and /etc/rc6.d directory output here. halt and reboot line is enough. –  max Dec 27 '12 at 12:00
    
@AlexisWilke paste the output of ls -l not ls like this lrwxrwxrwx. 1 root root 14 Dec 22 13:17 S01halt -> ../init.d/halt lrwxrwxrwx. 1 root root 14 Dec 22 13:17 S01reboot -> ../init.d/halt –  max Dec 27 '12 at 12:15
    
@max I have the same thing on my 12.04 install and that other computer works fine. Ultimately it calls this: reboot -d -f -i on both platforms. I'm thinking acpi may have something to do with it, if those servers acpi is not properly understood by the current kernel... –  Alexis Wilke Dec 27 '12 at 12:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.