Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install the TOR component obfsproxy.exe as a service using NSSM but it only works if I modify the service to logon as my own user account.

NSSM creates services with the logon account set to 'Local System'. When I try start the service Windows says 'Could not start, the service did not return an error'. The eventlog doesn't give any hints other than

Program C:\Program Files (x86)\obfsproxy\obfsproxy.exe for service obfsproxy exited with return code -1073741515.

If I change the logon user to my own user account (member of admin group) it works perfectly. What rights could my own account have that the 'Local System' account does not have. I dont want to force users to use their own accounts to start the service, I want to find out why it doesn't work and fix it so the default nssm installation works.

share|improve this question
up vote 1 down vote accepted

You should look at:

  • Network. Does obfsproxy.exe use any remote/mapped drives? Those will be specific to your account.
  • Registry. If obfsproxy.exe wrote settings to the user section of the registry when it was installed, those settings will not be available to the Local System account.

And be sure to check for a log file from obfsproxy.exe that documents a reason for its early exit...

share|improve this answer
thanks. obfsproxy.exe is a self standing executable and not part of an installer. It does not use any remote/mapped drives. I have put the log option in the list of arguments passed to the application when the service starts but it doesn't write anything to the log - it would seem that it exits before it opens the log for writing. – Michelle Dec 27 '12 at 16:58
Strange. What is the full command line you are using to launch obfsproxy? I just tried running obfsproxy.exe as a service with AlwaysUp - a commercial alternative to NSSM - and it runs fine as Local System. The command configured to run was "C:\Tor\obfsproxy.exe dummy socks". – CoreTech Dec 28 '12 at 6:06
I installed AlwaysUp and again it didn't work. I deduced that it must be an issue with the obfsproxy binary that I was using and so I downloaded the latest from TOR and now its working fine using NSSM! Thanks I wouldn't have solved it without your help. – Michelle Dec 28 '12 at 8:58

It appears obfsproxy.exe has some dependencies in the app directory of the tor bundle. Copying them seems to solve the issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.