Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a specific desktop which seems to have consistently high packet loss and ping regardless of what connection it is using. I'm connecting via wifi and this computer usually has a ping to my router of around 800ms and packet loss of around 20%. I've tried different wireless adapters, and even using the usb tethering on my phone, and they all have the same result.

The computer is running Windows Server 2008 R2 and Arch Linux, and the problem only exists on Windows for usb tethering. I can't test with the wifi adapters on Linux, as there are no drivers for them.

It is also not a locational or hardware problem. My laptop can connect without issue from the same position, either by using its own wireless adapter, a usb adapter which has issues in the desktop but is fine in the laptop, or usb tethering through my phone.

I've tried disabling 11n on my router so I know it's connecting by 11g, and it had the problem, and I tried setting it to 11n and it had the problem.

I've no idea on how to diagnose this. I can't find anything in my network settings which look likely to be the cause.

share|improve this question

Many things could be checked:

  • lots of network usage from that host? (use: wireshark )

  • lots of CPU usage resulting in a drop of network packets? (use Sysinternals "Process Monitor")

  • MTU settings: you could have a sub-optimal setting. I'd just do bigger and bigger ping with the "don't fragment" bit set, and see where it starts to break, and figure out then the best MTU setting (which is not the same number as the ping size, because of the ip and tcp headers overhead. Read about it for details). But beware: don't change more than 1 thing, and heavily test each time. You could completely mess up your connection!

  • routes: you may have conflicting things, such as several default gateways, etc, possibly generating unwanted traffic (such as useless duplicated packets).

share|improve this answer
I've checked all of these, and none of them seem to be the cause. Network usage is basically 0 and it's still problematic, CPU usage is about 40%, pings have the issue even if I set the size to 100, and I don't have several default gateways. – Macha Dec 28 '12 at 13:36
try to borrow a cable and see if, when connecting via cable, the situation is different. This will help pinpoint the real source (wifi card? tcp/ip stack? some hidden thing on the server itself?) – Olivier Dulac Dec 28 '12 at 13:43
Have you tried moving it? You list several other things, but you don't list moving it. If you have not, attempt to place the PC directly adjacent to the wireless router and see if it continues to have the same issue. If it does, you can eliminate wireless signal interference or connectivity...and probably the wireless card since you've already swap tested that. – George Spiceland Feb 23 '14 at 5:28

Whats disturbing to me, is the ping of 800ms to your router. This means almost a second gets lost in one-way traffic! This may not be higher then 20ms on busy occupied routers!

To me it sounds like you are not connected directly; There is, intentionally or not, some software or hardware that "hijacks" your signal. Most likely cause is a dialer or VPN that is open, and which causes a long timeout before it attempts secondary connections. Another possible cause could be that someone is listening in to your signal using the man-in-the-middle method, and is causing the delay this way.

Can you do a tracert to your router and to Also, verify that you are connected to the correct wifi network, and that the MAC of your router matches to the MAC that you are connected to. You can check if someone is mimicking your wifi network by using the following command in a cmd:

netsh wlan show networks mode=Bssid
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .