Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

At home we have 3 computers running Win7 Home Premium, x64. They are all members of the same workgroup. I can map a network drive by ip address but when I use the computer name I get "access denied". I've checked and double checked that the name and password are being typed correctly. The logged in user is a member of the Administrators group on all computers.

C:\>net use x: \\server\c$
The password is invalid for \\desktop01\c$.

Enter the user name for 'server': joe
Enter the password for server:
System error 5 has occurred.

Access is denied.

.

C:\>net use x: \\192.168.1.104\c$
The command completed successfully.

I could just use ip addresses to map drives and carry on, but we're using dhcp and the addresses could change without warning or notice (and I don't want to use static, the point is to reduce administrivia not add more!).

Any ideas how I can get net use \\computername\... to work too?

share|improve this question
    
possibly related superuser.com/questions/486777/… –  matt wilkie Dec 30 '12 at 6:01
    
I rarely use Microsoft FixIt, but I'm wondering if you should give it a try for this? At this point, it might be worth it. I would suggest running it on all of the computers in the workgroup. –  John 'Shuey' Schuepbach Apr 20 '13 at 13:10
    
I've also read several posts where people said this fixed the problem, but I'm doubtful it will fix it - I guess it may at least be worth a try: support.microsoft.com/kb/942974 –  John 'Shuey' Schuepbach Apr 20 '13 at 13:13
add comment

2 Answers 2

What about creating a new share on the server and calling it something simple like "C", then map to that instead of C$...? The problem is that you're trying to map to a hidden share, and Windows 7 doesn't make this as easy as XP did. Let me know if this option is not acceptable as part of your workflow and maybe we can come up with another solution.

share|improve this answer
    
I used $c as the example, but net use \\server\share fails too, only net use \\192.168.1.104\share succeeds. I don't have these difficulties on my other computer at work, however that computer is running Win7 Pro and is a member of an Active Directory domain. Perhaps this is an intentional restriction on Win7 Home Edition? –  matt wilkie Apr 19 '13 at 17:58
    
Windows 7 Home definitely does NOT handle networking exactly or as robustly (is that a word? :D) as Pro does. –  John 'Shuey' Schuepbach Apr 20 '13 at 23:36
add comment
up vote 0 down vote accepted

Finally got this one solved! Thanks to Joining Windows 7 Homegroup breaks connections to shares

The solution is turn off Homegroup sharing, and leave the Homegroup. After that folders can be shared via: select folder >> r-click >> properties >> sharing >> advanced sharing >> [x] share this folder >> permissions

Note: "select folder >> r-click >> share >> ..." gave an error and did not work, and neither does ... >> properties >> [share].

navigation path to successful sharing

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.