Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a nettop. It came with WinXP Home. I first installed Win 7 on it. I wasn't that happy with the performance so I decided to go back to XP. I am using an external dvd drive and a Win XP Pro disc.

I boot from the dvd drive and during the install get this error:

Setup did not find any hard disk drives installed in your computer.

Make sure any hard disk drives are powered on and properly connected to your computer, and that any disk-related hardware configuration is correct. This may involve running a manufacturer-supplied diagnostic or setup program.

Setup cannot continue. To quit Setup, press F3.

This is the nettop in question: http://www.newegg.com/Product/Product.aspx?Item=N82E16883103228

share|improve this question
add comment

5 Answers

up vote 4 down vote accepted

You need to go into the BIOS and see if there is something similar to "SATA Operation Mode" and set it from AHCI to IDE. This usually works if you cannot find the right AHCI driver.

share|improve this answer
    
Bingo. Many thanks. –  CT. Oct 8 '09 at 0:21
    
Ugh... Setup now finds the drives. Lets me delete the current partitions. But errors on formatting the partition. Unable to format partition. –  CT. Oct 8 '09 at 0:24
    
If you're doing a quick format, try doing a full. –  MDMarra Oct 8 '09 at 0:43
    
Yea, tried both. –  CT. Oct 8 '09 at 14:13
add comment

XP usually doesn't have the right SATA drivers on disk. You may need to find the SATA drivers and specify when you boot off the XP Disk that you need to use third party drivers.

share|improve this answer
add comment

This is most likely due to the way that the hard drive is loaded. I would look in the BIOS for any settings along the lines of "Hard Drive Mode".

Also, if you are using anything less than Service Pack 2, I believe that it has problems with SATA disks.

If you can not find this, it is likely that the manufacturers of your nettop will have a drivers disk that you can burn to CD and when windows setup loads, you press a key early on and it will load the hard disk driver.

share|improve this answer
    
Setup says hit F6 at some point to load third party drivers. Problem is when it is time to load said drivers it says: Setup could not find a floppy drive on your machine to load OEM drivers from a floppy disk. It has no floppy, will a usb external work? Anyway I could edit the installation disc image so that it includes needed drivers and burn a new cd? –  CT. Oct 7 '09 at 23:07
    
You really need to have them slip streamed into the CD, a separate CD in some situation, or a USB Floppy drive, unfortunately the text part of setup does not support USB. –  William Hilsum Oct 7 '09 at 23:30
    
Thats what I mean... Edit the disk image file. Then burn that edited disk image file to new cd. –  CT. Oct 7 '09 at 23:35
add comment

i never had a problem with SATA drivers, XP automatically detected HDD drives. The only thing I did when this error appeared was to shutdown the pc, unplug cables from HDD (power and data) and blow air into the sockets or clean them with a brush (sometimes if the cables are old, you can just replace them) after that re-power your system and restart instalation and it should detect your HDD drives

this worked fron me many many times :)

share|improve this answer
    
I don't think it is this as my Win 7 disc recognized them fine. It's also a week old machine, I doubt it needs cleaned. –  CT. Oct 7 '09 at 23:21
2  
XP does not have AHCI support built in like Vista and 7 do. It's common and doesn't require opening the machine and checking cables. –  MDMarra Oct 7 '09 at 23:52
    
i used to be an admin at a small company, but i can tell u that there i had a lot of problems with the PC's even if they were new or old, i just want to say that sometimes it works even if u unplug the cables and then put them back in, that easy :) (it takes 1 minute to try) –  Remus Rigo Oct 8 '09 at 1:16
add comment

You need to enter the BIOS and change the hard drive settings from AHCI to ATA. Save the changes, restart, boot to XP disk and VOILA!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.