Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a ton of music in my iTunes (Windows). When I go into Album View (or any view that has songs isolated by Album), in some random albums the song artist/composer is listed under the song. 99% of my songs don't do this and it bothers me that some of them do for no apparent reason. I've tried editing song information and I've compared songs with each other to see what is making certain songs do this, but found nothing. How can I disable this?

It should look like this:

1 American Idiot
2 Jesus of Suburbia
etc

not

1 American Idiot
  Green Day
2 Jesus of Suburbia
  Green Day
etc
share|improve this question
2  
Are you sure, these files don't have tags like composer or album artist? There has to be an information hidden somewhere in the tags. I suggest you, to use mp3tag portable and view+compare all tags of a good and a bad file. –  nixda Dec 28 '12 at 11:35
    
Thank you for pointing that out. I double checked my tags and figured out that iTunes will only update way the songs are listed when it is restarted. The songs that were being listed like that were missing the Artist tag. –  Redmastif Dec 28 '12 at 15:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.