Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got two routers. A D-link DSL and an Aztech HW5503g. I connect to internet through dlink. The default ip address of dlink is 192.168.1.1 and that of aztech is 192.168.2.1. As I want the computers connected in in two router to use the same subnet, i configured as said in http://routersetup.blogspot.in/2007/08/connecting-two-routers-wired.html ie disabled DHCP in aztech and connected the two routers on the numbered ethernet port (not WAN). Everything works fine. I can access internet with any router. The problem is I cant access web interface of second router( Aztech 192.168.1.2) when i connected through either of the router. How can I access the web interface in second router in this setup?

share|improve this question
add comment

4 Answers 4

up vote 2 down vote accepted

If I understand correctly, and just talking about the routing problem:

  • router1 IP/network is still 192.168.1.1/24 (or in other words, 192.168.1.1/255.255.255.0)
  • router2 IP/network has been changed to be 192.168.1.2/24 (iow, 192.168.1.2/255.255.255.0) ?

Did you really change his network to ? it seems as if you did not.

For example if you changed it to, say, 192.168.1.2/32 (or 192.168.1.2/255.255.255.255) it would explain the problem: any request outside of its lan (ie anything else than from 192.168.1.2/32) would then be routed to the default gateway if there are no specific routes saying something more precise, and that default gateway is probably on another interface altogether (wan?)

You should then:

  • reset router2 to its default
  • connect to its lan interface with a laptop/pc, with that laptop/pc in the good (default) network too (if your router has dhcp by default, just let it assign a correct ip. If not, put an IP on your PC that is in the same lan as the router2 default network, and on a different IP than the router2 default IP)
  • check network config: assign it the 192.168.1.2/24 ip (or 192.168.1.2 / 255.255.255.0)
share|improve this answer
    
Let me explain my situation. Router 1 is connected to internet through dsl. 192.168.1.1/24. Router 2 got 5 ethernet ports. 4 of them marked 1 to 4 and the 5th as WAN. If i connnect a cable between router 1 ethernet and router 2 WAN , pc connected to router 2 got internet and router2 assignes internal ips with 192.168.2.1/24. Now you cant see computers connected in router1 through router 2. So i changed the router 2 same subnet as that router 1 192.168.1.2/24 and disabled the DHCP. Now router 1 acts as the DHCP Server. (check the link in the question). –  dInGd0nG Dec 28 '12 at 11:36
2  
simpler could be : just go back to the first setup (router2 have its hosts on 2.x and provides internet via router1), and add on it a route saying "192.168.1.0/24 is also on the WAN interface, going to 192.168.1.1". and on 192.168.1.1 add a route saying "anything for 192.168.2.x/24 should go to router2's IP of 192.168.2.whateverhisipisinthatsetup(maybe dhcp assigned in that case, or you can fix it via assigning mac@ to, say, .1.2)" –  Olivier Dulac Dec 28 '12 at 11:44
    
otherwise (2nd setup): if you put both routers in same LAN, connect them with their LAN interface (and put their IPs on the LAN side). WAN interface on router2 is then unused (you could use it to create a separate lan, or a separate access to another internet gateway, or whatever) –  Olivier Dulac Dec 28 '12 at 11:48
    
if in the same lan, and if you still want to use router2 as a Wifi provider, it still can have its dhcp enabled, but both DHCP shouldn't overlap (ie, on router 1 give it, per ex, the range .10-.99 and on router2 the range .100-.199) –  Olivier Dulac Dec 28 '12 at 11:49
    
I am already in the 2nd setup as you said. The problem is that the web interface and telnet port are not open in this setup. My internet is just working fne on both routers –  dInGd0nG Dec 28 '12 at 12:07
add comment

You disabled DHCP but did not change the default statically assigned address on the Aztech. You'll have to reset and configure the routers address before you disable DHCP.

share|improve this answer
    
I have already done that. I changed ip of aztech to 192.168.1.2 and even assigned the mac address of aztech to this ip on dlink. I can see the aztech is assigned as 192.168.1.2 on the Dlink's ARP table. I cant even ping to 192.168.1.2. The whole setup works if I used the default config ie connect through the WAN port. But the problem is that they are two distinct networks –  dInGd0nG Dec 28 '12 at 8:12
add comment

Ok, going in setting the IP on the Aztech as something in the other routers range whilst still letting it be DHCP in the first step, then going back in and setting it to relay on in the second step solves the problem.

Assign the ip for the aztech router the same ip on the first router with the aztech mac address (reserve the IP).

Make sure attached PC is given a static ip in the range so it can talk to both routers.

share|improve this answer
add comment

You mentioned the aztech as being 192.168.2.1, and later as trying to reach it on 192.168.1.2. Was the first address a typo?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.