Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm having some issues with my Canon Pixma IP1900 printer - it doesn't respond to any OS requests. I am using Windows 7 x64 with additional Canon drivers and the printer used to work ok, but recently it doesn't anymore.

I've connected it to a second PC running on Win7 x86 and no additional Canon drivers and the printer worked again - not only did Windows find appropriate drivers all by itself, but everything else did work like a charm as well.

Now I assume that the problem is either the drivers (messed up by OS) or the OS itself. My idea is to completely remove Canon drivers and any data associated with the printer. How do I do it?

share|improve this question

1 Answer 1

up vote 9 down vote accepted

Take a look at this tutorial which explains how to use the Microsoft Management Console (MMC), to remove unwanted printer driver packages.

If that does not work for you, try using the printui.exe tool.

In an admin elevated command prompt type printui /s /t2, be sure to remove the driver AND the package.

Here's how to do it, step-by-step:

  1. Open a command line with administrative rights: Start->All Programs->Accessories->Command prompt; Right click -> Run As Administrator
  2. Run the printui tool: printui /s /t2
  3. Try deleting the printers. If that doesn't work... (i.e., if removing the printers listed in the printui is not successful.)
  4. Click Start > Run > Services.msc
  5. Locate the Print Spooler service, and right-click > Properties > stop service.
  6. Open My Computer and browse to C:\Windows\System32\spool\Printers (you will need to click "OK" to get access to the folder).
  7. DELETE the contents of the folder you opened in step 7.
  8. Go back to services.msc and Restart the Print Spooler service.
  9. Go back into the printui utility (you might need to restart it using same method as above) and try removing printers again. This time it should work. If necessary, check the "Ports" tab and remove any TCP/IP ports that are associated with the old printer.
  10. Last but not least, check other computers on your home network to see if any of those map to the old printer, and remove these mappings
share|improve this answer
1  
Well explained. Nice answer. –  CharlieRB Dec 28 '12 at 12:58
    
Everything you described worked (at least no errors were displayed). The problem is that after removing the drivers, rebooting and plugging in the printer I see the same problem - no connection with the printer can be established, though the printer works just fine with my x86 Windows 7.. How come? What else can I do / delete / reset ? –  elmes Dec 28 '12 at 13:39
    
Have you tried a different port or cable? –  James Young Dec 28 '12 at 14:12
    
Yes, I tried to change both.. –  elmes Dec 28 '12 at 14:14
    
It would help if you elaborate on the steps you took when installing the printer, perhaps your computer is not set to automatically search online for drivers. –  James Young Dec 28 '12 at 14:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.