Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two public IP, they have not given me any subnetmask and gateway for those two. But in seperate they have given me one subnet mask/gateway as below:

  1. 217.91.227.x
  2. 217.91.170.x

  3. To be use subnet:, gateway: 217.5.98.x

But how can i use those two ip with this subnet and gateway? I tried to add them in my router, but it says invalid input:

217.91.227.x with subnetmask and gateway: 217.5.98.x is not valid entry
217.91.170.x with subnetmask and gateway: 217.5.98.x is not valid entry

Then how do i setup my two linux box with those ip having subnetmask and gateway? Can anyone show some example or how it can be done?

(i am using Ubuntu, CentOS, Fedora and residential Cisco routers)


         [Default Gateway: 217.5.98.x]
[ A - Location ]<-----------> [ B - Location ]
   ^                           ^
   |                           |
[ Router 1 ]                 [ Router 2 ]
   ^217.91.227.x               ^217.91.170.x
   |                           |
[ PC 1 ]                     [ PC 1 ]
[ PC 2 ]                     [ PC 2 ]
[ PC 3 ]


  • Router 1 and Router 2 should have public IP, which i need to configure
  • Router 1 and Router 2 what subnet mask and what default gateway i have to use? when i am given with information to use as mask and 217.5.98.x ?
share|improve this question
Hello YumYumYum, can you edit and add a bit more detail about the nature of your connection? This looks like you must have a layer 2 connection to your ISP? – Paul Dec 28 '12 at 11:15
@Paul: see my EDIT diagram plz. – YumYumYum Dec 28 '12 at 11:34
I have to setup my A and B location. I Am confused what will be my router settings for those IP's? Is it /8 or /16 calculation i ave to use? Or is it a static routing? – YumYumYum Dec 28 '12 at 11:35
But what connection type is it? What do you physically plug into router 1? What protocol is it running? – Paul Dec 28 '12 at 12:41
up vote 0 down vote accepted is invalid with different gateway /8 is for loopback so it wont work nor /16 many routers allowed to insert. So ISP needs to give proper information, they are the culprit, confuse creator, they should be charged.

This problem was solved by changing the settings to PPPoE, which means is valid and i needed from ISP, username/password.

Solved the problem. (ISP;s are confusing, information was not given properly)

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .