Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just installed a fresh copy of Windows 8 on my desktop: After updating everything, and yes - even my graphics card I tried to start up Minecraft but I get a OpenGL is missing error.

Here's a DXdiag of my system,

And from it, my card:

Card name: AMD Radeon HD 7300 Series (Microsoft Corporation - WDDM v1.20)

I've updated my drivers and even tried to install it from Devices. I did notice that after installing, the Control Panel for my Graphics card is different and it's called AMD Vision Engine Control Center. I can't configure none of my flatpanel settings.... I kinda wish I never upgraded but it's to late now.

I'm really looking for help here, as I can't even get some features of Photoshop working, which is part of my job. I am really looking for a fix, thank you.

share|improve this question
Try installing the 12.11 Catalyst beta drivers – HackToHell Dec 29 '12 at 4:51
this, correct?… Did not work. – devs Dec 29 '12 at 4:52
up vote 0 down vote accepted

Go into Safe mode and run Driver Sweeper and remove all the display drivers(only display!).

Reboot back into normal mode and install the drivers again, it should be fixed if a corrupted install is preventing OpenGL files from registering.

The ATI ogl driver has not been registered, re installing will fix it, this driver must be registered


But it's not in your PC as seen from dxdiag dump.

share|improve this answer
Wouldn't this cause me not to use my screen? – devs Dec 29 '12 at 5:46
Your display will work even without the drivers. – HackToHell Dec 29 '12 at 5:57
This isn't a Windows 8 Issue? – devs Dec 29 '12 at 5:58
It could be, try this out and see if it fixes your computer – HackToHell Dec 29 '12 at 6:20
Okay. Went to safe boot, removed drivers. rebooted. reinstalled drivers from AMD site and it still doesn't work. Now I get this error: AMD Control Center can not start – devs Dec 29 '12 at 7:16

Afaik the default Win8 WDM drivers are only a stub. Neither of them (both on Nvidia or AMD cards) seemed to support OpenGL. Maybe because MS favours directX.

For me, it was resolved by installing vendor drivers, but on some machines bitmap fonts (wglusebitmapfont) seems to be corrupted.

share|improve this answer
Found the cause:some intel cards seem to dislike having a PBO bound while drawing wglusebitmapped fonts. – Marco van de Voort May 31 at 11:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .