Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an nfs share I'm trying to mount automatically at startup in ubuntu / xbmc

I have the following in /etc/fstab

nas:/mnt/raid /mnt/raid nfs noauto,rw,async

On startup the mount doesn't automatically occur.

If I issue a manual mount command it works:

$ sudo mount -o noauto,rw,async -t nfs nas:/mnt/raid /mnt/raid

How can I get this mount to occur automatically on startup?

Looking for errors in /var/log/messages doesn't yield much, but it does say something about nodiskmount:

Kernel command line: \
    BOOT_IMAGE=/boot/vmlinuz-2.6.32-29-generic \
    root=UUID=e575a39a-09d9-4747-befa-466c7aae64d1 \
    ro quiet splash \
    xbmc=autostart,nodiskmount \                       <-- THIS LINE
    loglevel=0 \
    video=vesafb

Could this be the problem? Is there any way to disable nodiskmount?

I am using the XBMCFreak LiveCD 10 from XBMCFreak.nl which is based on Ubuntu lucid lynx

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 10.04.2 LTS - XBMCLive
Release:    10.04
Codename:   lucid
share|improve this question
up vote 1 down vote accepted

Try changing “noauto” to “auto” in /etc/fstab.

share|improve this answer
    
D'oh! Thanks! :) – Steve Lorimer Jan 1 '13 at 6:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .