Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to setup Remote Desktop on my computer. It's currently running Windows 7. RDP is set to allow for incoming connections.

I've followed the instructions at PortForward.com, but am having no luck. Here's the details:

Router: TP-LINK WR841N -- WanIP=192.168.0.2, LanIP=192.168.0.1
                          DHCP Bounds = 192.168.1.100 (start) through 192.168.1.199

Computer Static IP (Assigned) = 192.168.1.151

External IP (whatsmyip.com) = 111.67.xxx.xxx

Also of note, I have port 3389 forwarded on the router to IP 192.168.1.151 and it is enabled for all protocols.

Now when I run PFPortCheck, I get "Could not test port 3389 because some other application has that port locked. Please close any applications that may be using this port and try again."

Now this is funny, as I have removed all antivirus and firewall software from my computer, and disabled Windows Defender.

So, I run "netstat -aon" and I get the following:

TCP    0.0.0.0:3389    0.0.0.0.:0    LISTENING    PID=1216

PID 1216 doesn't show in Task Manager, but using "tasklist" from the command line reveals that it's svchost.exe. So I killed the process with "taskkill /PID 1216 /F" and it magically terminated.

Returning back to PFPortCheck, I try to test the port again. Only now I get "We were unable to ping your router" and "Your port is NOT OPEN or not reachable!".

So, can anyone tell me how I can open this port so I can walk accross the street and RDP into it?

Thanks,

Jason

share|improve this question
    
Can you connect locally? Like from another computer in your LAN? –  barlop Dec 29 '12 at 14:43
    
What is the subnet mask for your WAN, and what is the subnet mask for your LAN? –  barlop Dec 29 '12 at 14:47
    
WAN subnet = 255.255.255.0 / LAN subnet = 255.255.255.0 –  Jason Dec 29 '12 at 15:06
    
Haven't had any luck connecting locally either, really not even sure how to try –  Jason Dec 29 '12 at 15:07
1  
A)You must succeed in connecting locally before considering the router. B)Your network's IPS are both overly complex, and the subnet masks don't match them either. A way of fixing your IPS, is make your computer's static ip 192.168.0.zzz And your DHCP 192.168.0.aaa to 192.168.0.bbb (where aaa is less than bbb). Then your subnet mask can be 255.255.255.0 At the moment given your LAN IP, Computer's IP, and LAN subnet mask, your computer's IP is not on your network so you'll have problems. –  barlop Dec 29 '12 at 22:24

1 Answer 1

I'm pretty sure the process that's locking 3389 is RDP itself. If you disable remote connections first and test again it should be able to test successfully, at least that's how it worked for me.

  1. Control Panel > System > Remote Connections
  2. Disable remote connections and Apply.
  3. Test again with port checker, could take a minute for RDP to release the port
  4. After you have your results you can re-enable remote connections and Apply

This should at least narrow it down for you, currently I have the ports test successfully after disabling RDP. Not sure what the rest of the problem is.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.