Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

User profiles on a win7 box I have the displeasure of administrating all got corrupted (windows would create a default fallback profile on each login).

I created a new profile (an administer) and transfered exiting profile files into it following this:

http://windows.microsoft.com/en-CA/windows-vista/fix-a-corrupted-user-profile

Something strange is happening. The new profile is unable to open explorer.exe

Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item. 

I tried a variety of things including confirming the permissions on C:\Windows\Registration:

http://www.tomshardware.com/forum/5218-63-cant-explorer#t170268

What I've noticed is that if I log in as a different new administrator user and open explorer.exe and then log in as the administrator with the problem explorer will work just fine.

What is it about the permissions on explorer.exe that cause this behavior?

What I want to achieve is to have the problem account open explorer.exe without having to log in as the other user first.

Thanks in advance.

Edit:

Here are permissions and Owner Screens of the offending profile:

permissions profile dir Owner profile dir

Here are permissions and Owner Screens of Windows dir:

permissions win dir Owner win dir

Here are permissions of explorer.exe:

explorer.exe perm

share|improve this question
1  
Checked for viruses, or Safe Mode, Sir? or have you accidently excluded all .exe files for that user in Group Policy, or is anything amiss at HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders –  James Young Dec 29 '12 at 21:59
1  
Could you show us a screen shot of the permissions? I would take ownership and then re-assign permissions. –  Guy Thomas Dec 30 '12 at 11:23
    
@GuyThomas Not sure what you want to see permissions of. I've attached screens of the offending profile and the Windows dir –  SMTF Dec 31 '12 at 6:52
    
@JamesYoung Safe mode looks good. Nothing looks obviously wrong with the Reg Keys –  SMTF Dec 31 '12 at 6:53
1  
Thanks for the screen shots, sadly when compared with my user permissions, I cannot see any problems or faults. Maybe that in itself is a clue. –  Guy Thomas Dec 31 '12 at 10:36
add comment

2 Answers 2

Make sure if the new account is correctly added to the administrator group; If it is indeed correctly added in administrator group, run a Malware scan, then run the following line on a elevated command prompt:

sfc /scannow

Your windows cd will be asked to be inserted if changes to your system are needed.

share|improve this answer
    
"Windows Resource Protection did not find any integrity violations." –  SMTF Dec 31 '12 at 7:24
1  
change the ownership of your %root%\windows folder and subfolders to your newly created account. that would solve the issue. (replace TrustedInstaller with your account name) –  Lorenzo Von Matterhorn Dec 31 '12 at 12:23
    
Does that have any unintended side effects ? –  SMTF Dec 31 '12 at 20:14
1  
none at all, since your newly created account is placed inside the admin group. –  Lorenzo Von Matterhorn Dec 31 '12 at 20:45
    
Interestingly it does not seem to have solved this issue ... –  SMTF Jan 2 '13 at 3:52
add comment

Try resetting all Windows file permissions to default.

In an elevated command prompt type the following command.

secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose

If that fails you can always try a system restore.

share|improve this answer
    
I get "The task has completed. warnings occurred for some attributes during this operation. It's okay to ignore the warning. See log %windir%\security\logs\scesrv.log for detail info." Problem still persists though. –  SMTF Dec 31 '12 at 20:13
    
I recommend you read this post. techsupportforum.com/forums/f217/… –  James Young Dec 31 '12 at 20:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.