Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have configured my home web server with Fedora. Now if I enter localhost or 192.168.0.1 in my address bar I can see the Apache test page. But if I enter my current dynamic ip on address bar then I see unable to connect. I did this before using inadyn and dns afraid but before I tried with LAN connection now I'm using wifi. I guess that's why I'm having the trouble. Because my Fedora desktop's IP is becoming 192.168.143.1 or something and default gateway ip is being 192.168.1.3. If I enter 192.168.143.1 then I can see the Apache test page too. But no luck for default gateway ip or dynamic IP.

Any suggestion how I can solve it?

I haven't changed resolv.conf because every time I connect to the internet it gets changed automatically by the network manager.

I don't have a router. I have a Samsung galaxy phone which I use as wifi hotspot. And my phone has a data connection.

share|improve this question

migrated from serverfault.com Dec 29 '12 at 21:34

This question came from our site for professional system and network administrators.

add comment

3 Answers 3

up vote 0 down vote accepted

You need to port forward port 80 from the router (phone) to the device on your local network (laptop).

Keep in mind this may not work as cellular providers may block inbound connections by default.

share|improve this answer
add comment

The issue is that your router doesn't support hairpin routing, or that functionality is turned off. To resolve this, you'll either need to get a new router or alternatively, have name resolution return a different IP address inside your LAN than it does outside.

share|improve this answer
add comment

Check the Apache configuration to make sure the httpd server is listening on that IP address. I set mine to Listen *:80 instead of the main IP address. I am running CentOS and the config file is in /etc/httpd/conf/.

You can verify it is doing a dynamic listen using netstat -an. You should see 1 entry for port 80 like this :::80. Do you have a firewall enabled? You may need to allow all access to port 80 from anywhere. Can you traceroute to the outside IP?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.