Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Some kind of program is stealing focus from the active window, it's quite strange. I am using Windows 7 Ultimate 64bit.

So for example I open Notepad++ and start typing. After some time (few minutes, sometimes even less), the window loses focus and the program does not receive input anymore. Same with other programs, it's quite annoying.

I already checked for malicious programs. The only change I made to the computer before the problem started occurring is the installation of a new TP-Link USB wireless adapter.

Anybody have an idea?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Because the only change I made in a reasonable time was adding the wireless adapter, I thought the problem should be related to that. I investigated by reverting things I have done step-by-step, first removing the wireless adapter, then closing software that came with it (using the Task Manager).

Turned out it was the TP-Link Wireless Utility.

Got rid of it and it is fine now. It is not necessary for the wireless adapter to function.

@Andrew Thompson reports that one and a half year after I posted this question this problem still has not been fixed by TP-Link.

share|improve this answer
    
Is there any method you used to track this down? Or just trial and error? Otherwise this question would simply be too localized to the one situation you had, and thus not really helpful for other visitors with the same issue. –  slhck Dec 30 '12 at 10:08
    
@slhck Basically started closing running programs from Task Manager. Since then I found out that this wireless utility is causing a lot of problems for other people too, so I thought it would be useful to share this. But no matter, this is my first closed question on SE, it seems to be fun :). –  kapa Dec 30 '12 at 16:21
    
DYM the 'TP-LINK Wireless Configuration Utility'? I seem to be having the same problem! –  Andrew Thompson Jul 15 at 4:09
1  
"Since then I found out that this wireless utility is causing a lot of problems for other people too" (raises hand) Just solved the problem on my machine over a year and a half after your answer, thanks to your heads-up. And this was for a new card (the guy that supplied it was grumbling that he'd quoted it to cost $X for the motherboard connector he was expecting, but it used the 'new style connector' and cost $X+10), some year and a half after your report. I disagree that it is 'too localized', though it seems a very poor software support effort on the part of TP-Link. :-/ –  Andrew Thompson Jul 15 at 4:44
1  
Sure thing, seems useful. –  slhck Jul 25 at 14:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.