Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently assembled my first computer but when completed, I pressed the POWER button and the only feedback I received was the PLED brightness. No fan (power nor cpu) rotation, no beep, no video.

I double checked my connections, all seem right. I didn't check the CPU because I do not have more thermal grease and I'm pretty sure it is well set in its socket.

I tried to remove hard disks and RAM but nothing changed. I tried to switch of RAM slot as well but fruitlessly again...

I hope the CPU is not damaged (although I am under warranty).

Does anyone have any idea ?

Sorry for the lack of information, here is the list of my components :

  • CPU AMD FX 6100 ;
  • MOBO ASRock 970DE3 ;
  • Case/PSU [Heden B9350CA][3] (PB00083041) ;
  • RAM [Kingstone HyperX Genesis][4] (PB00122039) ;
  • GC [Asus EN210][5] (PB00132287) ;
  • SSD [Kingstone SSD Now V+200][6] (PB00136039);
  • HDD [Seagate Barracuda][7] (PB00119952).

(As a new user I can't link more than 2 components, sorry.)

share|improve this question
    
what motherboard? Are there any error lights? Is this an intel based systems (there's a chance you could have bent a pin in the motherboard during install) or AMD –  Journeyman Geek Dec 30 '12 at 15:07
add comment

2 Answers

It's incredibly hard to remotely diagnose this, but essentially you need to follow a logical process of elimination. For this you will need another (functioning!) PC. Try swapping the new RAM with the RAM in the working PC - does it work? Same for PSU?

Try connection the new HDD - is it detected on the new PC?

If all is good above, it is probably either your processor or motherboard, which are obviously harder to diagnose. Ideal would be trying a "working" processor in the same socket etc. Unfortunately this is going to require more thermal paste.

Good luck!

share|improve this answer
    
I'm aware that remotely diagnose such issues is not a cakewalk, but I wanted to get some feedbacks from the community before contacting an expert or my seller. Unfortunately the only working PC at my home are laptops. I will check into the attic if I have an old PC somewhere. –  Antoine Pinsard Dec 30 '12 at 15:59
add comment

Best things to try:

Unplug all motherboard header pins (power button, power led e.t.c.). Try plugging in just the power button for now.

In addition, check that you have plugged the PSU in firmly and properly to the motherboard for both the standard long strip (2x12) and the cpu (2x4) power.

The fact that no fans powered up makes me certain that this is a power related problem... If it was simply the cpu or memory or other problem, fans would come on like normal despite there being a problem.

share|improve this answer
    
I tried it fruitlessly :/ –  Antoine Pinsard Dec 30 '12 at 16:52
    
@AntoinePinsard - I believe you have a faulty PSU or Motherboard then. –  William Hilsum Dec 30 '12 at 16:56
    
I'm more skeptical against the Heden PSU than the ASRock Mobo. I might have been better not to choose a "No name" PSU. Anyway, I'll check it with an professional tomorrow if the shop is open. Thanks for your help. –  Antoine Pinsard Dec 30 '12 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.