Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed PDFArchitect, which replaced the Foxit reader plugin in Firefox.

How can I set Foxit's plugin as default for handling in-browser PDF files?

share|improve this question

Go to tools>options>applications to make your changes.

How to change file associations in firefox

share|improve this answer

I would try this:

  1. deactivate the PDFArchitect plugin in Firefox via Add-ons-Manager/Plugins
  2. reinstall Foxit
share|improve this answer

The best way is to disable any other plugin that opens PDF files, then restart Firefox, and open the Tools > Options > Applications window. The Foxit plugin should appear in the dropdown list next to PDF files.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .