Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro5,5 running OS X 10.6.4.

I can connect to a certain WLAN using AirPort with a WEP password successfully, but the password is not remembered after each disconnection.

What's more, I do not even find an option to say that it should be remembered and unsurprisingly, the keychain has no entry pertaining to this connection.

How can I make my MacBook remember a WEP password (using Snow Leopard)?

I don't know if any of this is relevant, but for full disclosure:

This computer had the hard disk changed a year ago and a problematic backup from the old hard disk restored in an unconventional way. The hard disk change involved an upgrade from leopard to snow leopard, so the older entries in AirPort and KeyChain have been made using leopard.

share|improve this question
    
Is this only affecting one specific WiFi network or all? Can you change the WEP password, or even change authentication to WPA? Can you remove the network from the list of remembered ones in System Preferences » Network and then try connecting again? –  slhck Dec 30 '12 at 22:40
    
Unfortunately, I do not have access to another WiFi network for at least another week, and I have to use the WEP password here. I can remove the network and add it again, but when I enter the password in the System Preferences and press "Save", it then does not save it. –  Phira Dec 31 '12 at 13:11

2 Answers 2

Go to System Preferences>Network>Advanced>Wi-Fi

Delete that network from the list of preferred networks.

Then, rejoin the network from the menu bar. It should have an option to "Remember this Network." Check that box and see if that solved your problem.

share|improve this answer
up vote 0 down vote accepted

My problem has been solved and I want to describe the issue for others with the same problem:

The date of the system was set to 2001 (due to the hard disk change) and correcting it solved the WEP password issue (and many other minor issues).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.