Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is a somewhat general issue that I've been running into while trying to install Linux onto my late 2008 Macbook Pro.

I've tried the following distros:

  • Linux Mint 10
  • Linux Mint 14
  • Ubuntu 12.10
  • Fedora 17

What's happening is that at some point during the boot process, something the Macbook Pro doesn't like is crashing it. I think it is related to the gpu drivers, but I can't tell for sure. What happens is the system totally freezes and the top one-third of the screen is all corrupted.

I tried changing the runlevel to 3 so that X does not start while I was attempting to boot Fedora 17's live install, but a few seconds after getting the initial login prompt, it went all corrupted. Up to that point however, everything was fine.

It also does not seem to make a difference if I run the "windows" boot loader (which is a low-res shell) or the EFI boot loader (which is a high-res shell). Both exhibit the same behavior.

I did somehow manage to get Linux Mint to boot to a desktop on ONE occasion, however it froze shortly afterwards.

FWIW, Mac OS X 10.6 works perfectly fine on this machine. I also tried installing rEFIt, but that did not help at all.

share|improve this question
    
Have you tried going to another TTY prompt with Alt+F2 (or F3-6). See if that brings you to an interactive shell to check the logs and get different drivers. If you have nvidia, try the nvidia drivers instead of nouveau for example. –  nerdwaller Dec 30 '12 at 23:41
    
It's a full on, hard, crash. I tried doing ALT+F2/3/4/5/6 to no avail. –  Brendan Dec 30 '12 at 23:42
    
Odd... I'll try to do some more digging to see if I find any help. Obviously doesn't sound kernel specific since you tried at least one or two... –  nerdwaller Dec 30 '12 at 23:44
1  
I just tried adding nomodeset to the kernel params before booting, and it says X failed to start, but no corruption this time! Fell back to text mode... PROGRESS! –  Brendan Dec 30 '12 at 23:45
    
Couldn't get Fedora's text-mode install to let me manually change the partition table, so I tried adding nomodeset to Linux Mint 14's live CD and now I'm installing Linux Mint... crossing my fingers. –  Brendan Dec 31 '12 at 1:24

1 Answer 1

up vote 4 down vote accepted

I believe I figured out the cause of the issue.

It was indeed an incompatibility with the way the Apple hardware communicated with the VESA drivers, I believe when switching modes on the built-in screen. When nomodeset was added to the kernel parameters, system could proceed to boot without crashing.

The Macbook Pro is Late 2008, 5,1 with nVIDIA 9600m GT.

nomodeset is only necessary until you can install the proprietary nVIDIA drivers for your distro.

To recap:

  • Installed rEFIt while in OS X (run /efi/refit/enable.sh if rEFIt does not work automatically)
  • I ran the Mint 14 live DVD by adding nomodeset to the kernel parameters in the grub bootloader.
  • Ran Mint installer
  • Did partitioning
    • mounted / to /dev/sda4, also installed grub to this partition
    • swap on /dev/sda3 (because I placed some space in-between the Mac partition)
  • Finished mint installer, rebooted.
  • Booted from linux partition using rEFIt.
  • Again, added nomodeset to kernel parameters so I could boot.
  • Ran Software Sources application
    • Went to Additional Drivers tab
    • Selected first NVIDIA driver (proprietary, tested), applied changes
    • Waited for it to finish, then rebooted.
  • Booted into linux again and all was well (nomodeset automatically removed as it is a temporary change)

Phew.

share|improve this answer
    
lol took 8hrs to answer your own question. –  WeloSefer Dec 31 '12 at 7:31
    
Heh, yeah, had to watch the Redskins game inbetween. FWIW, I couldn't find anything about this issue online, it didn't seem like people were having the same issue, but I don't see how. –  Brendan Dec 31 '12 at 7:59
1  
Thanks for posting the full solution to your problem. Greatly appreciated, especially as I'm having the same problem :) –  Duncan Bayne Apr 3 '13 at 23:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.