Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I successfully setup 6in4 ipv6 tunnel to enable ipv6 connectivity at home using a remote linux box with a /64. The connectivity works well between the two host, but not with internet.

Here is my setup:

Linux box eth0: 2001:470:XXXX:XXXX::1
Linux box 6in4: 2001:470:XXXX:XXXX::2 --> 2001:470:XXXX:XXXX::3 prefixlen 128
Linux box 6in4: 172.16.0.1 --> 172.16.0.2
Linux box tun0: 172.16.0.1 --> 172.16.0.2/32
Home 6in4: 2001:470:XXXX:XXXX::3 --> 2001:470:XXXX:XXXX::2 prefixlen 128
Home 6in4: 172.16.0.2 --> 172.16.0.1
Home tun0: 172.16.0.2 --> 172.16.0.1/32

Home route: default dev 6in4 Linux box route: default 2001:470:XXXX:XXXX::ff (the gateway) Linux box route: 2001:470:XXXX:XXXX::4 via 6in4

From home, I successfully ping 2001:470:XXXX:XXXX::1 and 2001:470:XXXX:XXXX::2
From Linux box, I successfully ping 2001:470:XXXX:XXXX::3
From the outside, I successfully ping 2001:470:XXXX:XXXX::1
From the outside, I can't ping 2001:470:XXXX:XXXX::2 nor 2001:470:XXXX:XXXX::3
From the Linux box, I successfully ping the outside (google.com)
From home, I can't ping the outside

I have enabled the ipv6 forwarding: $> sysctl net/ipv6/conf/all/forwarding net.ipv6.conf.all.forwarding = 1

But it changes nothing. My guess is that if I manage to ping 2001:470:XXXX:XXXX::3 from the outside, I'll be able to access 2001:470:XXXX:XXXX::4 too.

It might be because the 'internal' ipv6 network needs to be different than the public one but then I'd need to NAT the traffic which ip6tables does not allow...

If someone has an idea, it would be greatly appreciated :)

share|improve this question
    
When I check the tcp traffic (tcpdump ip6), I see the ping comming from multicast when I try to reach ::2 or ::3, (or any non attributed address), but when I try to reach ::1 or an attribute address, I see the ping comming from the correct address. I don't get why :( –  louis8831 Dec 31 '12 at 3:12
    
You've obscured too much (and the wrong parts) of your IPv6 addresses. If you really feel the need to obscure them, change the first 32 bits to 2001:db8: (RFC 5156) and leave the rest intact. –  Michael Hampton Jan 1 '13 at 23:36
    
@MichaelHampton I am not sure to understand, I obscured only parts of my /64 prefix, as I can't change this part, I don't see in what it is relevant, maybe you could help me on this? It is true I often see 6in4 ips using the prefix, but then, how can it be routed trough the internet? –  louis8831 Jan 8 '13 at 3:03
    
@MichaelHampton everything I have obscured is constant. if you prefer, lets say that XXXX:XXXX is 1:1 –  louis8831 Jan 8 '13 at 3:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.