Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After Doing a (cold) boot I have no internet connection.

But I actually can restore the connection with Window's Network Diagnostics:

According to the diagnostics the problem is

"No valid IP-Configuration"

and is solved by "resetting the LAN-Connection".

However, the problem persists and I have to run the diagnostics after every boot. Is there a way to fix this permanently?

EDIT: While trying some commands I found that 'ipconfig /renew' gives a time out error:

"DHCP-Server not found"

share|improve this question
1  
How long do you wait before declaring 'No connection'. I sometimes have to wait 5 minutes before I get my Internet Connection. –  Guy Thomas Dec 31 '12 at 20:26
    
I have waited for more than an hour. –  Emerson Dec 31 '12 at 20:35
1  
Sorry to hear that. I did a little more research, this article suggests changing (disabling) the firewall. tinyurl.com/aaw3l3k –  Guy Thomas Dec 31 '12 at 21:35
    
Thanks for trying to help. I tried what was mentioned in the article, but to no avail. –  Emerson Jan 1 '13 at 13:22

2 Answers 2

Before I gave up on Windows 8 I had this same issue with a new Samsung Chronos 7 notebook. It turned out to be a driver issue and updating driver from Samsung resolved it. Whatever was going on seemed like the WiFi was very slow in initializing with the older driver. So check to see if there is a updated driver for your NIC.

share|improve this answer
up vote 0 down vote accepted

Solved by:

Computer -> Manage -> Device Manager -> Network Adapter -> [Your Adapter] -> Power Management -> uncheck all boxes here

Kudos to Viking_667.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.