Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using both Linux Mint and Windows 7 on my laptop.

I can use the network printer in my office area flawlessly in Windows 7, which seems to use the LPR protocol and requires my ID and password.

When I go to Linux, here comes the problem. I set up the network printer with CUPS but cannot find anywhere to set my ID and password for the print service. It turns out that I can send the file for print to the printer successfully (indicated in the CUPS status) while the printer dose nothing but prompts an error.

Here are the settings for the printer under win7 and linux:

Win7:

win7 1

url for another:

win7 2

Linux:

linux 1

I tried id@"printer address", but it seems this setting cannot be saved (the device URI gets back to "printer address" after I press Apply.)

HERE IS THE SOLUTION kindly found by @slm:

Check out this ubuntu issue, bugs.launchpad.net/ubuntu/+bug/124442, go to the #8 comment, he shows a way to provide the info I think you need to lpd. – slm 1 hour ago

share|improve this question
    
Is the network printer accessible via ipp://<name of printer> or is it shared out via another windows system or even Samba? –  slm Jan 1 '13 at 0:12
    
@slm: LPR, like it says. –  Ignacio Vazquez-Abrams Jan 1 '13 at 1:19
    
Yeah you said it "seems to use" so I wanted further clarification. Is the printer hosted by a windows box or is it on the network itself? –  slm Jan 1 '13 at 1:59
    
@slm: Thanks for your reply. I don't know how to check whether the network printer is accessible via ipp. I have uploaded 3 pics to indicate the my settings in both Win7 and Linux. As you can see, the network printer is under LPR. –  Lagrange Jan 2 '13 at 1:50
    
Check out this ubuntu issue, bugs.launchpad.net/ubuntu/+bug/124442, go to the #8 comment, he shows a way to provide the info I think you need to lpd. –  slm Jan 2 '13 at 2:29

1 Answer 1

up vote 1 down vote accepted

Can you run the app, system-config-printer from a terminal? If so it will come up like so:

           printing dialog

Click the Add button brings up this dialog. NOTE" You'll most likely be prompted for root's password at least once or twice.

       new printer dialog

Select Windows Printer via SAMBA.

      new samba printer dialog

EDIT #1

After a discussion with @Lagrange it was determined that he had the following Fuji Xerox printer "FX DocuCentre-II C7500 PS". The following page was found over on the Ubuntu issue tracker.

Fuji-Xerox engine for CUPS

The #8 comment on this thread contained the solution. I'm excerpting it below so this question/answer can stand on their own.

Hi,

based on the above comments, I've made some .deb packages:

1) original source code from ftp://download.fujixerox.co.jp/pub/exe/apeosport/c4300series/fxlinuxprint-src-1.0.1.tar.gz, licensed under GNU GPLv2
2) get the driver to output the required headers for printing to printers with mandatory auditing (FXUserName setting)

Also:
3) fixed a slight problem with the PPD file that meant the printer wasn't visible in the GUI "add printer" dialogs
4) tried to fix up some potential insecure uses of strcat() function.

.deb packages and my changes to the source code are available at http://www.wlug.org.nz/~jrm/fxlinuxprint/

To set the FXUserName variable for auditing, do one of:

a) [GNOME]
  click on System -> Administration -> Printing
  right-click on the printer, go to Properties, go to Job Options.
  At the bottom, enter "FXUserName" (case-sensitive) into the "add a new option" box, and click Add. Then set the value to the correct printer accounting code.

b) [command line, requires root permissions]
  stop the printing service (CUPS) with '/etc/init.d/cups stop'
   edit /etc/cups/printers.conf, and inside the <Printer> or <DefaultPrinter> blocks, add a new line like 'Option FXUserName 123456'.
  Now restart the printing service with '/etc/init.d/cups start'.

c) (change setting for local user only)
  From the command line, enter "lpoptions -p (printername) FXUserName=123456",
  replacing "123456" with the correct printer accounting code for your department. You can find the printername for the already known printers with 'lpstat -a'
  Note! some applications that don't fully support the CUPS printing system
  (such as Open Office) will not correctly apply the option if it's set using this method.
  http://user.services.openoffice.org/en/forum/viewtopic.php?f=16&t=36474

@ryanau - I couldn't find any way to get the CUPS interface to allow a text entry dialog like that (except for adding your own option like in step a) above). I think the PPD interface only allows "PickOne"-style options.
share|improve this answer
    
Thanks. Actually, I tried to use SAMBA but failed. –  Lagrange Jan 2 '13 at 1:50
    
HERE IS THE SOLUTION kindly found by @slm: Check out this ubuntu issue, bugs.launchpad.net/ubuntu/+bug/124442, go to the #8 comment, he shows a way to provide the info I think you need to lpd. – slm 1 hour ago Thanks to all invloved –  Lagrange Jan 2 '13 at 3:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.