Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried using the following registry file to add Sublime Text 2 to the Default Programs list in Windows 8 Enterprise x64. It doesn't show up. All the paths are correct. This method has worked for other programs and works on Windows 7 Professional x64 (using an identical .reg file).

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile]
@="Sublime Text Document"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile\shell\open\command]
@="\"C:\\Program Files (x86)\\Sublime Text 2\\sublime_text.exe\" \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile\shell\edit]

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SublimeText.textfile\shell\edit\command]
@="\"C:\\Program Files (x86)\\Sublime Text 2\\sublime_text.exe\" \"%1\""

[HKEY_LOCAL_MACHINE\SOFTWARE\Sublime Text 2]

[HKEY_LOCAL_MACHINE\SOFTWARE\Sublime Text 2\Capabilities]
"ApplicationDescription"="Sublime Text is a sophisticated text editor for code, markup and prose."
"ApplicationName"="Sublime Text 2"
"ApplicationIcon"="C:\\Program Files (x86)\\Sublime Text 2\\sublime_text.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Sublime Text 2\Capabilities\FileAssociations]
".txt"="SublimeText.textfile"
".xml"="SublimeText.textfile"
".html"="SublimeText.textfile"
".js"="SublimeText.textfile"
".nfo"="SublimeText.textfile"
".conf"="SublimeText.textfile"
".json"="SublimeText.textfile"
".cnf"="SublimeText.textfile"
".config"="SublimeText.textfile"
".css"="SublimeText.textfile"
".less"="SublimeText.textfile"
".sass"="SublimeText.textfile"
".scss"="SublimeText.textfile"
".haml"="SublimeText.textfile"
".coffee"="SublimeText.textfile"
".compass"="SublimeText.textfile"
".mustache"="SublimeText.textfile"
".erb"="SublimeText.textfile"

[HKEY_LOCAL_MACHINE\SOFTWARE\RegisteredApplications]
"Sublime Text 2"="SOFTWARE\\Sublime Text 2\\Capabilities"
share|improve this question

Try using Default Programs Editor.

Default Programs Editor makes it easy to fix file association settings in Windows, including context menu items, icons, and descriptions. Also: autoplay settings and default programs settings ...all without fiddling around in the registry.

share|improve this answer
2  
try explaining what it does in your answer – Shekhar Jan 1 '13 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .