Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When connecting my Nexus 7 to my Windows 7 computer, it doesn't show up in neither Windows Explorer > My Computer nor Device Manager > Portable Devices.

I did, however, install the Google USB driver, which allows USB debugging for Android development, and that driver shows up under Device Manager > Android Devices

enter image description here

Also, when the Nexus 7 is connected via USB to the Windows 7 Computer, the setting on the device is correctly selected/checked to connect as a media device: Notifications (Swipe down) > USB Computer Connection > Connect as Media Device (MTP)

However, when I connect my Galaxy Nexus phone, it shows up in both Device Manager > Android Devices and Device Manager > Portable Devices, which in turn shows up under Windows Explorer > My Computer allowing me to actually use it as an MTP device.

enter image description here

How can I access my Nexus 7 as a media device under Windows 7?

share|improve this question
    
Android phones typically ask for permission before going into storage device mode. I'm surprised your phone hasn't done that. Is it possible that it did and you missed it? –  Isaac Rabinovitch Jan 1 '13 at 23:20
    
It's possible that this happened on the Nexus 7. But if it did, how can i make it ask for permission again? –  TheDarkIn1978 Jan 2 '13 at 3:20
    
Same issue here.. naked drivers do the same, only thing is now it says Nexus.. but still no storage drive. –  hikari Feb 26 '13 at 20:10

1 Answer 1

up vote 12 down vote accepted

As I posted in this question on Android.SE, I was able to get my MTP mode working again. FYI I don't know how this affects the debugging interface since I haven't checked that out yet, but this should let you access it as a drive.

From that answer (slightly modified based on your images):

What worked for me (on Windows) was:

  1. Plug the Nexus 7 into your computer with the USB cable.
  2. Open Device Manager.
  3. Find "Android Device" near the top and expand the node. Double click on "Android Composite ADB Interface".
  4. In the properties window that pops up, uninstall the driver (I chose to delete the current driver as well, not sure if that matters).
  5. Unplug the tablet and plug it back in.

At this point mine got recognized as a Nexus 7 instead of an Android ADB device and allowed me to transfer files again.

share|improve this answer
1  
This didn't work for me. I can't update the driver since Windows 7 tells me that the currently installed driver is the most recent version. Deleting the driver and then plugging back in the device only reinstalled the same driver. –  TheDarkIn1978 Feb 20 '13 at 11:39
    
That's too bad. I was so happy when I got it working. Perhaps you can try installing the naked drivers? –  Richard Marskell - Drackir Feb 20 '13 at 12:36
5  
I chose to delete the current driver as well, not sure if that matters - this matters. It looks like this problem appears when you are using another (second) Nexus 7 device on the same computer. After I did all the steps here, MTP worked with a fresh drivers copy from Windows Update, but ADB got broken. Using drivers from support.asus.com/download.aspx?SLanguage=en&m=Nexus%207 fixed that and all is working - for now. –  demosten Mar 31 '13 at 15:34
    
This worked for me. I replaced my Galaxy Nexus phone with a Nexus 5 and was unable to get MTP working on the Nexus 5 until I uninstalled and deleted the old driver. –  Stefan Mohr Jan 4 at 19:23
    
Everything works for me now, but I'm still not sure why. It only started working after I updated my Nexus 7 to Android 4.4 (Kit Kat, which is not supported for the Galaxy Nexus phone) and then updated the driver from Asus's website. So now my Phone is using Android 4.3 and my tablet is using Android 4.4 and they now both connect as MTP devices. I'll accept your answer as correct based on votes. –  TheDarkIn1978 Jan 24 at 12:07

protected by Community Jan 20 at 23:52

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.