Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When i do upgrade or install, im getting this error.

srikanth@btp8sa42:~/projects/raff$ sudo apt-get upgrade
[sudo] password for srikanth: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libcurl3-gnutls : Depends: libc6 (>= 2.15) but 2.13-20ubuntu5.3 is installed
               Depends: libgnutls26 (>= 2.12.6.1-0) but 2.10.5-1ubuntu3.2 is installed
               Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.9.1+dfsg-1ubuntu2.3 is installed
 libp11-kit0 : Depends: libc6 (>= 2.14) but 2.13-20ubuntu5.3 is installed
E: Unmet dependencies. Try using -f.

When i do "apt-get -f install"

srikanth@btp8sa42:~/projects/raff$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 libcurl3-gnutls : Depends: libc6 (>= 2.15) but 2.13-20ubuntu5.3 is installed
               Depends: libgnutls26 (>= 2.12.6.1-0) but 2.10.5-1ubuntu3.2 is installed
               Depends: libgssapi-krb5-2 (>= 1.10+dfsg~) but 1.9.1+dfsg-1ubuntu2.3 is installed
 libp11-kit0 : Depends: libc6 (>= 2.14) but 2.13-20ubuntu5.3 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

cat /etc/apt/sources.list

# deb cdrom:[Ubuntu 11.04 _Natty Narwhal_ - Release amd64 (20110427.1)]/ natty main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://in.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://in.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://in.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://in.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://in.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://in.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://in.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://in.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse
# deb-src http://in.archive.ubuntu.com/ubuntu/ natty-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu natty partner
# deb-src http://archive.canonical.com/ubuntu natty partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu oneiric main
deb-src http://extras.ubuntu.com/ubuntu oneiric main

How can i fix this?

share|improve this question
    
Show us your sources: cat /etc/apt/source.list /etc/apt/source.list.d/* –  BatchyX Jan 1 '13 at 11:05
    
Actually its not the problem with apt-get, its due to some dependency. changed the title. –  Srikanth Jan 1 '13 at 11:25
    
Sorry, but this looks the same to me. If you don't want to give us your sources, then try with aptitude -f install instead of apt-get, or try to resolve the dependencies manually, with apt-get install libc6 libgnutls26 libgssapi-krb5-2 libc6 for example. –  BatchyX Jan 1 '13 at 11:33
    
Added source.list. apt-get install libc6 libgnutls26 libgssapi-krb5-2 libc6 doesnt work –  Srikanth Jan 1 '13 at 11:43

1 Answer 1

up vote 1 down vote accepted

Your sources indicates that you are on Ubuntu Oneiric. Your libcurl3-gnutls and libp11-kit0 depends on libc6 >= 2.15, which simply does not exist in Ubuntu Oneiric. That mean that these two packages (and possibly more?) are not for Oneiric, and shouldn't have been installed. If you forcibly installed these packages, this is a really bad idea. Don't do this.

Theoretically, your system is hosed. Ubuntu is not designed to properly support downgrading. Doing it works most of the time, but not always.

To remove these out-of-distro package and restore them to the version present in Ubuntu's Oneiric, use this :

apt-get install libp11-kit0/oneiric libcurl3-gnutls/oneiric

aptitude -f install should be able to solve it by itself, unless there is more to this hosed system, like another package depending on these uot-of-distro versions.

But really, the proper solution is to not install packages which do not belong to your distribution.

share|improve this answer
    
That solved my problem. Thanks BatchyX :) –  Srikanth Jan 2 '13 at 6:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.