Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last time I was trying to hide the menu bars in my existing database.

I added code in my module which I found on the internet. But now when I start Access I can't find the menu bars where I can usually see the File, Edit etc.

I tried to restore the default, the menu bar can't be found under the customize toolbar. Any idea what happened? This is added from the website:

Dim i
For i = 1 To CommandBars.Count
CommandBars(i).Enabled = False
Next i

I tried it but it didn't solve the problem. confused:(

share|improve this question

4 Answers 4

From this Microsoft Support article:

Reset the toolbars in Access 2003

Important : If you reset the toolbars in Access 2003 to their original settings, you may lose the custom changes that are implemented in the toolbars.

  1. Start Access 2003.
  2. On the Tools menu, click Customize.
  3. On the Toolbars tab, click to select the Menu Bar check box on the Customize dialog box.
  4. Click Reset, and then click OK.
  5. Click to select the Database check box, click Reset, and then click OK.
  6. Click Close.
share|improve this answer
    
i tried this one already reset the toolbars, the problem is i don't see the Menu bar on the customize dialog box. Even after clicking on the reset button. this is really strange, already tried to restart my PC but still the menu bar is still missing. this is weird... –  tintincutes Oct 8 '09 at 9:25
    
Might it not be a simpler solution to uninstall and reinstall Access? –  harrymc Oct 8 '09 at 10:35
    
i guess this is the last recourse I wanna do. thanks for the help.that's a lot of work again, it makes me not to like microsoft more. –  tintincutes Oct 8 '09 at 10:40
    
Microsoft's relationship with the world is a love-and-hate affair. –  harrymc Oct 8 '09 at 11:45

To restore all your menus you just need to change your code so it says 'true' instead of false

Dim i

For i = 1 To CommandBars.Count

CommandBars(i).Enabled = True

Next i

Hope that helps

share|improve this answer

I finally figured this out! Right click at the top of the page by your toolbars, the Customize box appears. Click Properties...popup "Toolbar Properties" appears. At the top of that selected toolbar, select MENU BAR, and click restore defaults at the bottom. The menu bar should appear back at the top of your screen. Hope this helps!

share|improve this answer

This worked for me:

commandbars("menu bar").Reset
commandbars("menu bar").Enabled = True
commandbars("menu bar").Visible = True
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.