Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a FreeBSD 9-Stable server, with nginx. My configuration is here:

user www www;
worker_processes 5;
error_log /var/log/nginx/nginx-error.log;
events {
    worker_connections 1024;
}
http {
    include mime.types;
    include fastcgi_params;
    index index.html index.htm index.php;
    default_type application/octet-stream;
    log_format   main '$remote_addr - $remote_user [$time_local]  $status '
    '"$request" $body_bytes_sent "$http_referer" '
    '"$http_user_agent" "$http_x_forwarded_for"';
    sendfile on;
    autoindex  on;
    tcp_nopush on;
    tcp_nodelay on;
    ignore_invalid_headers on;
    gzip on;
    server {
        listen 127.0.0.1;
        server_name localhost;
        location /nginx_status {
        stub_status on;
        access_log off;
        allow 127.0.0.1;
        deny all;
        }
    }
    server {
        listen 80;
        server_name localhost cubox.me *.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        root /var/www;
        location ~ \.php$ {
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index index.php;
#            fastcgi_param SCRIPT_FILENAME /var/www/$fastcgi_script_name;
        }
    }
    server {
        listen 443;
        server_name localhost cubox.me *.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        ssl on;
        ssl_certificate server.crt;
        ssl_certificate_key server.key;
        ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers RC4:HIGH:!aNULL:!MD5;
        ssl_prefer_server_ciphers on;
        root /var/www;
        location ~ \.php$ {
            fastcgi_pass 127.0.0.1:9000;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME /var/www/$fastcgi_script_name;
        }
    }
    server {
        listen 80;
        server_name yk.cubox.me yubikey.cubox.me yubico.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        location / {
            proxy_pass http://localhost:8000;
            proxy_set_header  X-Real-IP  $remote_addr;
        }
    }
    server {
        listen 443;
        server_name yk.cubox.me yubikey.cubox.me yubico.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        ssl on;
        ssl_certificate server.crt;
        ssl_certificate_key server.key;
        ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers RC4:HIGH:!aNULL:!MD5; 
        ssl_prefer_server_ciphers on;
        location / {
            proxy_pass http://localhost:8001;
            proxy_set_header  X-Real-IP  $remote_addr;
        }
    }
    server {
        listen 80;
        server_name munin.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        root /var/www/munin;
    }
    server {
        listen 443;
        server_name munin.cubox.me;
        access_log /var/log/nginx/nginx-access.log main;
        ssl on;
        ssl_certificate server.crt;
        ssl_certificate_key server.key;
        ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers RC4:HIGH:!aNULL:!MD5; 
        ssl_prefer_server_ciphers on;
        root /var/www/munin;
    }

}

My problem, actually, is that I dont have any log! /var/log/nginx/nginx-access.log or -error.log are empty. The server is running, restarted after config edit.

drwxr-xr-x  27 root  wheel       512 31 déc 14:45 var
drwxr-xr-x   6 root        wheel    1,5k  1 jan 22:41 log
drwxr-xr-x  2 www     www       512B  1 jan 21:28 nginx
-rw-r--r--  1 www  www  0  1 jan 21:28 nginx-access.log
-rw-r--r--  1 www  www  0  2 déc 16:48 nginx-error.log

The both files are not written by nginx, but user www have access to them.

╭─<root@Dragonborn>-</var/log/nginx>-<22:44:38>-◇
╰─➤ ps aux | grep nginx
root         29015  0,0  0,0  29140    16 ??  Is    6déc12     0:00,01 nginx: master process /usr/local/sbin/nginx
www          29016  0,0  0,2  29140  3300 ??  R     6déc12     2:56,20 nginx: worker process (nginx)
www          29017  0,0  0,1  29140  2692 ??  S     6déc12     3:04,70 nginx: worker process (nginx)
www          29018  0,0  0,2  29140  3224 ??  R     6déc12     3:06,69 nginx: worker process (nginx)
www          29019  0,0  0,1  29140  3008 ??  S     6déc12     2:54,06 nginx: worker process (nginx)
www          29020  0,0  0,1  29140  3032 ??  S     6déc12     2:53,29 nginx: worker process (nginx)

The server don't have any other problem, running fine.

Thanks for your help.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

I think the problem could come from this piece of setting:

server {
    listen 127.0.0.1;
    server_name localhost;
    location /nginx_status {
    stub_status on;
>>>>access_log off; <<<<<<<<<<<<<<<< You are setting them to be off
    allow 127.0.0.1;
    deny all;
}
share|improve this answer
    
Oh, My, God. Indeed, this part of the code disable all the log. How can I disable the log only for status now ? –  Cubox Jan 5 '13 at 15:25
    
I must say I don't know why it blocks all the logs… what happens if you don't set it? It shouldn't log anything for your 'status' server as there aren't any defaults settings and it should let all the other logs go on. –  No_or_yes Jan 6 '13 at 14:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.