Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A couple of days after a clean install of Ubuntu 12.04 (no other OS) the right click functionality on my USB Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) quit working on anything anywhere. Everything else works fine, but it is like it is like the right mouse button is completely disabled.

BTW, I've made sure the mouse is working on another system, No problems. Changed out the mouse with another that was verified to be working fine. No change. It's not the mouse!

The xinput list | grep 'id=' line command returns:

⎡ Virtual core pointer id=2 [master pointer (3)]

⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]

⎜ ↳ Microsoft Microsoft 3-Button Mouse with IntelliEye(TM) id=8 [slave pointer (2)]

And the xinput get-button-map 8 line command returns:

1 2 3 4 5 6 7

Anybody have any good ideas?

share|improve this question
1  
What do you mean by "no change" in the second paragraph? Are you saying the other known good mouse also didn't work? –  Grizly Jan 2 '13 at 4:47
    
Yes. I tried two different units that are known to work on other systems and worked on this system, as well, prior to installing Ubuntu 12.04 and even for a couple of days after I installed Ubuntu 12.04. The point being that I'm 100% sure it is not a problem with this mouse or any other mouse. The problem is with some aspect of Ubuntu 12.04 –  Nick Jan 2 '13 at 5:18
    
Did you try all of your usb ports? –  Kevin Jan 2 '13 at 5:27
    
Apparently gtweakui might fix it, change Desktop to "Use Nautilus to draw desktop" –  Grizly Jan 2 '13 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.