Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Ubuntu 32 bit on i7 processor. I tried to compile and install this package called xgrafix, I have installed dependencies, but now it has error as follow:

samir@samir-HP:~/Downloads/xgrafix$ ./configure --with-X11_LIBDIR /usr/lib/i386-linux-gnu/
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type: /usr/lib/i386-linux-gnu/
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking build system type... Invalid configuration `/usr/lib/i386-linux-gnu/': machine `/usr/lib/i386' not recognized
configure: error: /bin/bash ./config/config.sub /usr/lib/i386-linux-gnu/ failed

I have tried several thing but was unable to resolve this.

share|improve this question
up vote 0 down vote accepted

Just making a guess here. Assuming that this particular configure script is written using make you might need to change

--with-X11_LIBDIR /usr/lib/i386-linux-gnu/  to

--with-X11_LIBDIR=/usr/lib/i386-linux-gnu/  (added the assignment operator)
share|improve this answer
    
Thanks... it worked.. i figured that out... many many thanks... and if some one has compilation error related to Tcl/Tk, may be using latest version of source code would help. – Samir Chauhan Jan 2 '13 at 12:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .