Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to put a simple html page for anyone, accessing my IP address via browser. I havent installed any third party web server (like XAMPP), because I assume it already works: pointing browser tohttp://localhost/` gives no error, but a blank page.

Still, I cannot find where the webroot folder is.

IIS is not installed. Putting index.html in Users/Public/Public Documents does not work.

share|improve this question
2  
open the command prompt and type in netstat -an - do you see anything listening on port 80 in the column Local Address? If yes then something is installed that works as a web server. If not - you cannot do this without installing IIS in the first place. Additionally you can start wireshark before accessing the localhost to see the headers and check what kind of www server is responding - if something is trully responding. –  mnmnc Jan 2 '13 at 10:37
    
Thank you. It confirmed, that I have some webserver installed. Then the question changes - how do I locate it? –  Justinas Dūdėnas Jan 2 '13 at 10:40
    
try to search for c:\inetpub\wwwroot –  mnmnc Jan 2 '13 at 10:41
    
@mnmnc c:\inetpub\wwwroot exists, but it isn`t active, either. –  Justinas Dūdėnas Jan 2 '13 at 10:43
1  
This behavior can be caused by your router or anti virus or any third party browser add-ons. –  Dave Jan 2 '13 at 13:57

1 Answer 1

If localhost gives a blank page and no error, that doesn't mean that a webserver is running. It probably only means that the hosts file links localhost to 127.0.0.1 and nothing more. If a webserver was running, it would generate a result (webserver is working or something) or an error.

And yes you can put a blank html index file in the root folder, and that would result in a blank page as well. But no webserver does that by default, so you should have done that yourself.

So the default root folder, that depends on the server you're running, and as you're probably not running any webserver, there is no web root folder.

share|improve this answer
    
According to @mnmnc comment, if port 80 is listened, there must be some webserver. Don`t you agree? –  Justinas Dūdėnas Jan 2 '13 at 10:48
    
@JoshCampbell No no no no! IIS and Apache are not the only webservers "out there". If you do not have any of them that does not mean you do not have a web server. If something is listening on the port 80 - you have something configured , some service that will respond to address http://localhost. And you will not get a blank page if nothing is listening. IE will say that cannot display the webpage, Chrome says webpage is not available. –  mnmnc Jan 2 '13 at 11:06
    
@JustinasDūdėnas You need to install wireshark and start listening on the interface to see what is responding to the request sent while you try to access http://localhost. Search for a lines that begin with HTTP/1.1 200 OK or something similar - those lines will indicate response from webserver of anykind. If response from port 80 will have something different in the first lines - this will mean something other than webserver is configured on this port and it is most likely misconfiguration as port 80 for the sake of clarity should be reserved for http protocol communication. –  mnmnc Jan 2 '13 at 11:12
    
@JustinasDūdėnas or even better - install Process Explorer from Microsoft Technet - you will see the list of the processes runnning. Choose a process, open it's properties and there is a tab named TCP/IP - you will see the connections opened. If for any process you will see the port 80 on the left column (Local Address) then this is a process that is listening on port 80. –  mnmnc Jan 2 '13 at 11:18
1  
@JoshCampbell We are not discussing the possibility of serving the webpage without one of popular webservers. The discussion is about seeing blank page in a browser even if IIS or Apache is not installed. For example if other service is installed and configured to listen on port 80 - it will send some response to browser after connecting. This will not be a html but some unicode chars for example. Browser will accept and interpret this as empty response and will display the blank page. Connection on the network layer has been established hence no error message displayed by browser. –  mnmnc Jan 2 '13 at 11:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.