Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got zsh 5.0 installed via brew on OS X Mountain Lion.

I used something to set up this lovely value for PROMPT:

%B%F{yellow}%K{yellow}%{█▓▒░%}%B%F{white}%K{yellow}%n@%m%b%F{red}%K{yellow}%{░▒▓█%}%b%F{red}%K{black}%{█▓▒░%}%B%F{white}%K{black} %D{%a %b %d} %D{%I:%M:%S%P} %}%B%F{yellow}%K{black}%~/%b%f%k

However, there is no setting for PROMPT in my .zshenv, .zshrc, .zlogin, or the files in /etc.

I have a rather vague memory that I might have installed some addon that has something to do with this, but I cannot recall what. None of my . files seem to contain the setting.

is there an option to zsh that will cause it to reveal what it is reading when it starts up?

share|improve this question

The answer turned out to be:

prompt fire

which sets PROMPT.

share|improve this answer

It looks like you have some zsh sugar (like oh-my-zsh) installed. Check for ZSH=… in your .zshrc and if it’s set it gives you the clue where to find your PROMPT.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .