Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am experiencing significant certificate generation issues in Windows 8.

The first issue I encoutered was with Hyper-V being unable to generate a certificate. See this question for more detail: Hyper-V not working on Windows 8.

Since then, I've tried to deploy a self-signed application through click-once. When clicking Create Test Certificate I receive this message:

Access is denied. Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)

After I receive that error, I can manually choose the certificate that was generated by selecting Select from File.... Then, when I try to install the deployed application, I receive this error:

Cannot continue. The application is improperly formatted. 
Contact the application vendor for assistance.

I am running VS as an administrator. Am at a total loss on how where to go next. Any suggestions?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I guess you don't have read access.

Right click on the file, and ensure that you have read access. Or, give that right to Everyone just to quickly test and then by user.

Some times, the key lives here C:\Users\All Users\Microsoft\Crypto\RSA which also needs to be updated.

share|improve this answer
    
Are you saying the file is generated without issue and I can't read it? Where would I updated the permissions? Seems like I would want to update the folder-level and not the file level since I would just get the error the next time I try to generate a certificate. –  James Hill Jan 2 '13 at 13:31
    
Well, in my development area, we have to apply certs, and I had this issue (although applying the certificate myself, I wasn't getting denied error messages when trying to access it through VS/debug mode). The location is in my post. –  Dave Rook Jan 2 '13 at 13:32
    
You're right, I don't have read access. Granting it does not solve my issue though. See edits. –  James Hill Jan 2 '13 at 13:42
    
@JamesHill Actually, it did. You just have a new problem though! Change the platform target to Any CPU and publish again. I think the issue will be due to your manifest file is not well formatted (despite being a generated file)! –  Dave Rook Jan 2 '13 at 14:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.