Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Virtualbox 4.0.10 under Debian stable with Oracle VM VirtualBox Extension Pack 4.0.18r82821 to host an MS-Windows XP virtual machine for embedded software development.

Unfortunately the VM option Settings -> USB -> "Enable USB2 (EHCI) Controller" doesn't show up, and the Windows guest only sees USB 1.1 (OHCI). USB 1.1 works, but is of course quite slow.

I have a hunch that the reason is that my machine (a Thinkpad T420s) has USB 3.0, but I couldn't find any info despite searching quite thoroughly.

share|improve this question

I haven't been able to properly pass USB3 ports (even with USB2 devices attached) into a VBox VM... Try a straight USB2 port if you have any.

share|improve this answer
    
I can't enable USB 2.0 for the whole virtual machine, so I don't think it works on any port. – starblue Jan 2 '13 at 23:19
    
In that case, Have you followed the guide on Linux USB support? virtualbox.org/manual/ch12.html#ts_usb-linux – BowlesCR Jan 3 '13 at 16:53
    
As far as I can tell, yes. I'm in group vboxusers, and I don't think I have an older system (usbfs is not used in my system). – starblue Jan 3 '13 at 18:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .