Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Linux Mint 14 on my Samsung R580 laptop. The Fn-keys worked out of the box, I can switch screens, adjust volume and so on.

When I try to adjust the brightness (Fn + /), the slider shows up and moves to the left and right, but screen brightness does not change at all, it always stays at 100%.

I tried to change the brightness in the system settings and it also doesn't do anything.

When I'm inactive for 5-10 minutes, the energy saving profile kicks in and the screen is dimmed. So the dimming does work, but not when I change it manually.

I found some threads stating that you should change the acpi_background setting to "vendor" in Grub config, but that didn't change anything for me.

What else can I try?

share|improve this question

3 Answers 3

up vote 5 down vote accepted
+50

From Samsung R580, Ubuntu 10.04 and Brightness control, not written for Mint but may still work :

Edit the /etc/X11/xorg.conf file and add the RegistryDwords line (only that line) to the Device section:

Section "Device"
  Identifier "Default Device"
  Driver "nvidia"
  Option "NoLogo" "True"
  Option "RegistryDwords" "EnableBrightnessControl=1"
EndSection
share|improve this answer
    
thank you so much, my eyes love you ;-) accepted and bounty awarded. only the last line is relevant, the rest of my device section looked a bit different. and a restart was required. but now everything is more than fine –  moeTi Jan 12 '13 at 8:20

For linux mint version 8 +

  • gksudo gedit /etc/default/grub
  • Find the line which says GRUB_CMDLINE_LINUX=""
  • enter acpi_backlight=vendor between the quotes ("")
  • sudo update-grub
  • reboot your laptop / pc

Source:

share|improve this answer
1  
Welcome to superuser. Please try to add essential facts from the site to your answer. Otherwise, if the link goes down, your post will be totally useless. –  TFM Jan 3 '13 at 3:30
    
thank you, but I already tried that. the FN keys are working, I see the slider moving when I'm using FN+up/down. But the screen brightness does not change at all –  moeTi Jan 3 '13 at 11:49

Edit this line in /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Then:

update-grub
reboot
share|improve this answer

protected by Community Oct 27 '13 at 18:38

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.