Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to replace the HD in a MacBook Pro (2009) with a Samsung SSD 830. The SSD has previously been used in a MacBook (late 2008, aluminium) without issues.

Since very little differs in the specification for the two computers, I just installed the drive and booted. It worked for a while, but after a hard reboot (due to other issues) it started to behave strangely, processes were locked up, and I couldn't shut down cleanly. I tried to reinstall Mac OS X v10.8 (Mountain Lion) over the existing installation, but it would not complete. I then erased the disk through Disk Utility and tried a fresh install, without any luck. I'm able to partition it, but the installation locks up.

I then removed the drive and connected it to another Mac with a USB-to-SATA adapter. Over this connection I was able to install OS X. When I tried the same with the MacBook Pro, the whole installation completed successfully, so I reinstalled the drive inside the computer and booted, and it seemed to work until I ran migration assistant, which failed. (The syslog was full of errors of core processes that couldn't read from "(null)".) I then tried to use rsync to transfer my data, but I got a write error followed by "broken pipe". Just to check I removed the drive again, connected it over USB and run rsync again, without issues.

I have yet to try it inside the original MacBook again, but so far my experience is that it works when connected over the USB-to-SATA adapter, but not over the internal SATA connector in the MacBook Pro. The S.M.A.R.T status shows no problem. What could possibly be the reason?

share|improve this question
    
I have since reinserted the SSD in the 2008 aluminium Macbook, and have not experienced any of the problems I got on the Macbook Pro. Seems like a problem with the SATA controller in the newer computer (though it is the same Nvidia MCP79 AHCI in both). Still a little nervous. –  Daniel May 2 '13 at 21:21

1 Answer 1

I'm afraid I can't specifically tell you why it didn't work from one machine to another, only that I have had the exact experience you describe with a Kingston SSD (V200/256 GB), in similar machines (15" aluminium MBP and 13" 2009 unibody MBP).

I have a feeling it was due to some interaction between built-in garbage collection on the disk and something the OS was doing. This based purely on the fact that the locking up was fairly random, in both occurrence and length, but it seemed more frequent during heavy disk access (in particular, activities you mention - installing the OS and rsync'ing data back into place).

Over USB the disk was fine, presumably because OS X treats a USB mass storage device differently from an internal SATA device.

Unfortunately, the remedy in my case was fairly extreme: I spoke to Kingston and they kindly replaced the drive with a V+200/240 GB. Slightly smaller, but more modern controller and totally stable (a couple of months now).

Looking at the specifications for the Samsung 830, they use a differently-named controller from the V200/256 GB, so this isn't necessarily the same issue, and likewise the Samsung 840 uses a different controller from the V+200/240 GB, but I figured it was worth letting you know that there may not be a solution to this problem.

(N.B.: I tried turning TRIM on and off on the OS using various patches available online, but it didn't seem to make any difference.)

share|improve this answer
2  
Thank you for your reply, Leo! (And my apologies for not thanking you earlier - due to private issues far more serious I've not looked further into my the SSD problem since I wrote the question.) Might I ask if both your MBPs had the issue, or if you just like me was able to use it in one but not the other? –  Daniel Feb 27 '13 at 15:15
    
No problem Daniel. No, it was not quite the same, as I never tried the same SSD in the aluminium MBP, but I did use a different SSD in both machines, a V100+/128GB, and that was fine in both. So the V100+/128 worked in both, and the V200/256 showed very similar errors to what you describe in the 2009 MBP, and finally the V200+/240 worked in the 2009 MBP. Seems like that '+' makes all the difference... –  Leo Feb 27 '13 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.