Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I was given an MSDN subscription and the notifying email gave my email address as the username, but no password. Since that didn't seem to be adequate, I am attempting to set up an account, but it won't send me the email to finish the process. What might the problem be?

It gets to the "Call us overprotective, but we need to verify that your.name@company.com is yours", but it never sends an email. (No, it is not in the junk email.)

The MS Chat person didn't know why it wasn't sending, and suggested I ask the question in their forum, which of course requires a Live login.

I did manage to get to a change password page, I changed it to a password without any special chars (based on a fight I had with Live a few years ago), and I can see the account exists, because my security question is there.

I just checked, and I can send and receive emails from outside our company.

Since millions of people successfully have MSDN subscriptions, there must be something I am doing wrong. What?

Update: The last time I requested an email to be sent, I got the following error: "Volume Licensing Service Center has experienced a problem in completing your action.Error code:1001 [df58961c-10ee-45ca-a613-82059f638861]" It also had an email address, so I've sent an email asking for help. But, if they're having problems sending emails, their chat person should have known that.

share|improve this question
1  
Is the MSDN e-mail address black-listed in your companies firewall/spam-filter? –  Kruug Jan 2 '13 at 19:19
    
Hmm...I'll go ask. It seems unlikely, but I'd better check anyway. –  thursdaysgeek Jan 2 '13 at 19:24
    
I had this happen to me for a long time. For my situation, it turned out that I registered for MSDN using my yahoo email, but Microsoft was actually sending messages to my Hotmail account. Perhaps your situation is similar. –  Josh Campbell Jan 2 '13 at 19:58
    
@Kruug - make that an answer and I'll accept it. That appears to have been what happened. Since others here have MSDN, it seemed unlikely that an email from the domain microsoft.com would be blocked. –  thursdaysgeek Jan 2 '13 at 21:40

1 Answer 1

up vote 1 down vote accepted

Check your employers firewall/spam-filter as it may have been a black-listed e-mail address.

share|improve this answer
    
I had checked my own junk email box, but it had never gotten that far. –  thursdaysgeek Jan 2 '13 at 22:13
    
This is really something the MS Chat helper should have pointed out. –  thursdaysgeek Jan 2 '13 at 22:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.