Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been using uTorrent for a long period of time, but recently I noticed that when I open uTorrent, I can't make my laptop go to sleep. The screen turns off and etc. but it will be still running and I should hold the power button to shut it down.

I also tried exiting it and no difference. I tried stopping all torrents and then exiting it, no difference. (and by "exiting" i really mean exiting, not just closing the window!)

I searched about this and only thing I found about it was this and as you can see, no real answers.

I also tried unchecking "Prevent standby if there are active torrents" in settings. Didn't work!

And this is what I get when I use powercfg /requests in cmd:

DISPLAY:
None.

SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0269&SUBSYS_104311A3&REV_1001\4&2d8ce5ba&0&0001)
An audio stream is currently in use.

AWAYMODE:
None.

And it is the same before and after opening uTorrent.

Any solutions would be highly appreciated :) Thanks in advance.

share|improve this question
3  
When it is the same before and after using uTorrent: What makes you think that uTorrent is causing this? Maybe theres another bad guy involved. –  nixda Jan 2 '13 at 19:29
    
@nixda Because I have no problem sleeping my computer. It works fine, but every time I use uTorrent, this problem happens. I'm not saying it's "impossible" that it's not caused by uTorrent, but it's the most likely reason. –  Behdad K Jan 2 '13 at 20:00
1  
@nixda He means the output from powercfg /requests is the same before and after running utorrent. –  Darth Android Jan 2 '13 at 21:13
1  
After you closed uTorrent, did you check Task Manager's Processes tab to see whether uTorrent.exe had really disappeared from the list? It's quite possible it (and/or some associated process) is still stuck doing something in the background. –  Karan Jan 2 '13 at 21:45
3  
Process Explorer might be able to help you track down any associated processes/hooks. –  Karan Jan 3 '13 at 7:24
show 7 more comments

4 Answers 4

Go to:

Options -> Preferences -> General -> Prevent standby if there are active torrents

Make sure this is unchecked.

If this wont work,

Go to BIOS: Disable: "Wake up on LAN".

share|improve this answer
    
Well, this was the very first thing I did. No difference :( –  Behdad K Mar 10 '13 at 8:58
6  
I don't think Wake-on-LAN has anything to do with this. WoL is for waking a computer up when it is already asleep or turned off. It shouldn't prevent the computer from entering a sleep state. –  oKtosiTe Mar 11 '13 at 11:02
    
Try it please! And tell me does it work :) –  Davidenko Mar 11 '13 at 11:03
1  
Has anyone even tried to go into bios? It works! –  Davidenko Mar 11 '13 at 11:23
1  
@Davidenko Tweaking BIOS doesn't work. uTorrent is still preventing the computer from going into sleep, even when the list of active or stopped downloads/seeds is completely empty. –  Desmond Hume Jul 24 '13 at 14:53
add comment

This may not be entirely what you need: uTorrent 2.x has a scheduler somewhere in the options dialog. One of the options there is "Turn Off". I imagine that could be useful. With any luck, those settings are available in more recent versions uTorrent.

Although I'm uncertain about the next suggestion, you could try disabling settings as indicated in the screen shot. The reason being disc-sync (write, read) calls are a common source of activity that would prevent the OS from sleeping. Setting a higher memory cache size will consume more of your ram, but give you more time between disc access. Also using these settings implies a risk of losing downloaded (but not yet written out to disk) data in the event of uTorrent crashing, being forcibly shut down, if your computer crashes, bla bla bla.

Green: on
Red: off

utorrent cache settings

share|improve this answer
    
Thanks, applied what you said (except the last two checkboxes which weren't enable in uTorrent 3.2), but I'm really busy doing university projects, so I may respond a little late. –  Behdad K Mar 15 '13 at 21:02
add comment

It sounds to me that uTorrent is opening an audio stream and then failing to release it and or keeping it open. I do not know how to stop uTorrent from doing this as it sounds more like a bug to me then anything, but you should be able to ignore your Realtek driver when your computer attempts to sleep.

If you open the command prompt and issue the following command:

powercfg -requestsoverride "DRIVER" "Realtek High Definition Audio" "System"

Then execute:

powercfg -requestsoverride

You should see "Realtek High Definition Audio" listed under [DRIVER]

At this point an exception is registered for your realtek driver and should thus prevent any sleep related issues.

EDIT

For those who face a similar issue, but have a different powercfg -lastwake or powercfg /requests response this command can be modified and may help you.

You can override a system, display, or awaymode request issued by any process, driver, or service in windows 7.

Assume that uTorrent itself was indicated as the process that last woke your OS.

powercfg -requestsoverride "PROCESS" "utorrent.exe" "System"

Will override any system requests issued by "utorent.exe"

Lets say you want to override all requests by uTorrent:

powercfg -requestsoverride "PROCESS" "utorrent.exe" "System" "Display" "Awaymode"

Replace "utorrent.exe" with any process that may be waking your PC.

Other options can be found with the command powercfg /? This command will prevent your system from waking from any process, driver, or service given the proper command.

share|improve this answer
    
I don't think it's related. Realtek High Definition Audio appears in the list whenever some audio is being played, and it just happened that the OP was playing something when he was running powercfg. But the audio driver never gets in the way of going into sleep (I've got the very same audio on my machine, so I know for sure). –  Desmond Hume Jul 25 '13 at 19:27
    
@Desmond Hume In my experience I have found audio streams to be the culprit in the majority of sleep related issues. It may not be the driver itself at fault, but the fault of a process or application somewhere using the driver, in this case potentially utorrent. This doesn't necessarily fix that issue, but rather provides a workaround to it by overriding the driver. It would be interesting to see if this command produces any results for the OP –  Jason Bristol Jul 25 '13 at 19:36
    
@JasonBristol Since it's a long time I've asked this question, I've been using BitTorrent for some time and I can't approve your answer. I'm wondering if Desmond is having the same problem or just interested. If he can do this and report back, that would be great, otherwise, I'll install uTorrent again. –  Behdad K Jul 27 '13 at 10:56
    
@BehdadK2 I've been having the same kind of problem with uTorrent, never with my Realtek Audio. –  Desmond Hume Jul 27 '13 at 13:51
    
@DesmondHume This solution doesn't address an issue with your audio driver, it addresses an issue with an application that uses your audio driver by telling the operating system to ignore your audio driver when attempting to sleep. Again, from the looks of it uTorrent is accessing your audio driver which is preventing your operating system from sleeping. –  Jason Bristol Jul 27 '13 at 18:33
show 4 more comments

From your comments, it seems that µTorrent has not fully closed when you try to suspend. This is an expected default behavior, since µTorrent has the bt.graceful_shutdown option activated by default. This option, as you can figure:

Graceful shutdown is for when torrents take too long to write, normally µT will close in 10 seconds, with graceful shutdown, it wont close until all the data is saved.

Meaning, that µTorrent hasn't ended writing up all the data to the disk (they are still in the Windows cache) and since you have a Laptop with slower Hard Disk, this could take a while.

You can disable this option going to Preferences > Advanced > bt.graceful_shutdown and set it to false. WARNING: This could provoke that your torrents/data gets corrupted, so it's better to wait until µTorrent finish up.

If you are going to suspend after you finish, why not let µTorrent to do so?

µTorrent has a feature to automagically do actions when all downloads (or downloads/uploads) are finished. One of this (as you can see in the screenshot) is Standby when Downloads Complete, which you might find very useful and secure.

Stack screenshot thanks to Soft32

share|improve this answer
    
Thanks for your answer. I remember that I used to give my laptop about 10 or 15 minutes and it didn't sleep, but if Desmond can approve this answer, I would accept the answer. –  Behdad K Jul 31 '13 at 16:33
    
@BehdadK2 you can accept the answer independently of the bounty, if it solved your problem, since "all bounties are completely independent of and unrelated to accepting an answer.". Read more here blog.stackoverflow.com/2010/06/improvements-to-bounty-system –  Braiam Jul 31 '13 at 16:43
    
Actually I wasn't really thinking about the bounty, just searching for the correct solution :) –  Behdad K Aug 1 '13 at 17:08
    
@BehdadK2 Did mine solved your problem then? –  Braiam Aug 1 '13 at 17:11
    
As I said before, It's a long time I'm not using uTorrent anymore. I'm using BitTorrent and haven't had this problem. –  Behdad K Aug 2 '13 at 18:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.