Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used to have this problem on my Windows XP, and then Vista computer and managed to find a fix to stop it happening - but I can't find any information this time round.

I am using IE8 and Windows 7 Ultimate (RTM).

When I attempt to drag an image from a webpage to my desktop, or a local folder I get a dialog with the question: Do you want to allow files from this website to be copied to your computer:

alt text

How can I get rid of this, so that I can drag and drop without any interuption?

I know it was possible in previous versions of Windows as I overcame it. I also have a recolection that it is not an IE setting but instead an OS one (bourne out by the comment here).

share|improve this question
    
I think, but I'm not sure, that if you change the security zone for the web, you won't get prompted for this. My opinion, of course, is that you're missing the point of security in the first place. It's why we have condoms. – user3463 Oct 8 '09 at 13:55
    
And just like condoms, when we find a long term partner we stop using them. Consider that I am wanting to save images from a website I trust. – Martin Jan 16 '10 at 11:04
    
is there another source for "the comment here" link? I'm asked to login. @Randolph: this same warning appears for pages which are in the IE Trusted Sites list. – matt wilkie Jul 19 '10 at 16:28
    
Matt: The page pointed to by the link appears to have gone AWOL. – Martin Jul 19 '10 at 21:29
up vote 2 down vote accepted

I finally found the solution thanks to this website. Right click on your Desktop and make a new text file. Open it and paste the code below in. Once that is done, go to File, Save As, and change Save as type: to All files (*.*). For the file name put value.reg. After that simply double click on the file to add it to your registry.

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4]
@=""
"180B"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Internet Settings\Zones\4]
@=""
"180B"=dword:00000000
share|improve this answer

I dont know if anything have changed since Windows 7, but using Windows 10 and IE11 i found that the previous registry fix failed. But if i entered "Internet Options > Security" and modified anything and pressed "Apply" then the registry fix worked. If i changed anything in the other zones, the fix sometimes stopped working. If i applied the registry fix to other zones, the fix stopped working.

To get it to work every time, here is exactly what i did in the correct order:

  1. Opened both IE11 and Edge on a page which had a image.
  2. Reset everything in Internet Options, then closed the dialog (but kept the browsers open).
  3. Applied the registry fix as described in the previous answer.
  4. Opened "Internet Options > Security".
  5. Dragged the security slider down to "Medium", released the mouse key, then dragged it up to "Medium-high" again.
  6. Pressed "OK".
  7. Confirmed that dragging and dropping a picture from either of the browsers onto my desktop did not produce the security dialog.
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .