Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to set up my Google talk on jabber.el to chat from Emacs. My Emacs version is 24.2.1 and jabber.el version is 0.8.0 (at least, this is what jabber-info tells me). My configuration is:

        JID: yotama9@gmail.com
        [ ] Disabled
        [ ] Password: 
        [X] Network server: talk.google.com
        [ ] Port: 5222
        [X] Connection type: Value Menu Legacy SSL/TLS

and the message I get (after C-x C-j C-x) is:

Opening TLS connection to `talk.google.com'...
Opening TLS connection with `gnutls-cli --insecure -p 5223 talk.google.com'...failed
Opening TLS connection with `gnutls-cli --insecure -p 5223 talk.google.com --protocols ssl3'...failed
Opening TLS connection with `openssl s_client -connect talk.google.com:5223 -no_ssl2 -ign_eof'...failed
Opening TLS connection to `talk.google.com'...failed
Jabber connection failed
yotama9@gmail.com/nil: connection lost: `nil'

I tried searching for this problem and couldn't find any. I'm using this behind organization firewall.

share|improve this question
up vote 1 down vote accepted
[ ] Password:

Don't you need your password for yotama9@gmail.com put in for this to connect? According to google:

In order to connect to Google Talk and start sending IMs, you'll need to enable TCP connections to talk.google.com on port 5222, or on port 443.

Make sure to use port 5222 or 443 not 5223

share|improve this answer
    
If I give the password Emacs just hang without connecting. Also, here they tell me I don't need to do so. – Yotam Jan 3 '13 at 9:24
    
I read that it says "You can set the password of the account, so you don't have to enter it when you connect. Note that it will be stored unencrypted in your customization file. " This means you either have to set it in the configuration, or enter it when you connect. Also, correct what port you are using, per my answer. – Everett Jan 3 '13 at 9:27
1  
Thanks. 443 did the trick. – Yotam Jan 3 '13 at 10:21
    
@Yotam - Glad to be of service. – Everett Jan 3 '13 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .