Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a director called Public. It's a shared dir in network. I also have a file doc.odt in direcory docs I'd like to share the doc.odt file through the link.

I have done this:

ln -s ~/docs/doc.odt ~/Public/doc.odt

Then I opened nautilus and went to:

smb://alef/Public/

But the file is not shown.

So, how to share linked content?

share|improve this question

2 Answers 2

Since your smb:// url didn't work over the network I'm going to assume that Samba isn't configured and running on the machine that is serving out files. If it is, then you might need to try the IP address instead of the NetBIOS name.

Otherwise, you first need to make sure that the computer that will be serving the files is running Samba (since you're accessing it via the 'smb' protocol). You can look at this documentation for a very basic how-to on setting that up.

If you're running selinux on the computer you plan to server files from, you might want to look at this blog post regarding the setting up of proper permissions in selinux for Samba to work.

Cheers.

share|improve this answer
    
Samba works, because i see other files under: 'smb://alef/Public/' –  xliiv Jan 3 '13 at 20:52

You may need to tell Samba to allow following symlinks.

To do so, edit your samba configuration file (probably /etc/samba/smb.conf), and set these two option in the [global] section :

follow symlinks = yes
wide links = yes

The first one allows samba to follow symbolic links, and the second one allow it to follow links pointing outside of the shared directory.

More details here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.