Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About once a day when I go to gmail's website using Desktop Chrome, Windows 8 asks which app I want to use to send email. I select gmail, my current/always default, and it shuts up briefly. However the next day or so the message always comes back. There's no checkbox for "always use this method" or anything and I haven't changed the app to use for mailing or even used any other mailing app.

How can I get it to use gmail and only gmail and stop asking me?

Default programs popup screenshot

share|improve this question
5  
Please state which web browser you're using, and whether you're using it in Modern UI/Metro mode or Desktop mode. I think this could have something to do with it. For what it's worth, using Chrome and Firefox in Desktop mode, I am unable to reproduce this behavior. –  allquixotic Jan 3 '13 at 13:19
    
@allquixotic added –  Ben Brocka Jan 3 '13 at 14:10
1  
I have been having this same problem, and @Peadar's solution does not help. I have set Chrome to be the default mail handler both in Chrome and in Windows' "Default Programs" control panel. Still, I get the same pop-up every time I visit Gmail in Chrome. –  Ryan Feb 4 '13 at 18:34

3 Answers 3

Maybe this link will help you: http://support.google.com/mail/bin/answer.py?hl=en&answer=10966

Making Gmail your default mail application

You can designate Gmail as your default mailto handler. This means that when you click on any hyperlinked email address, a Gmail compose window will open so you can send a message to that address from Gmail.

If you use Windows: Download the Gmail Notifier. Right-click the Notifier icon in your system tray, and select Options. Check the box next to Use Gmail for internet mailto: links. Click OK. If you decide later that you don't want to use Gmail as your default email application, simply uncheck the box.

share|improve this answer
    
Hm it SHOULD be the default mail handler but it may have forgotten that in the upgrade; I set that in Win 7 and I'm unsure which settings all transfer. I'll check this out when I have access to the PC –  Ben Brocka Jan 3 '13 at 14:09

I was having the same problem.

The solution for me was to go to "Control Panel\Programs\Default Programs\Set Default Programs", select the "Mail" app (the standard app the comes with Windows 8) and set that as the default mailto handler.

Then I rebooted my PC, don't really know if that was neccesary.

After the reboot I went back to "Control Panel\Programs\Default Programs\Set Default Programs", selected "Google Chrome" and set that as the default mailto.

I haven't seen the popup since.

share|improve this answer
    
Just gave that a shot, but the popup came right back. –  Ryan Feb 13 '13 at 20:16
    
Do you allow Chrome to run in the background? I was just able to make the popup reappear now by removing the check mark from "chrome://settings/" > "Show advanced settings..." > "Background apps" at the very bottom of the page. –  Niklas Feb 13 '13 at 21:27
    
I don't allow Chrome to run in the background. That could be a fix, but I don't want it to run in the background. –  Ryan Feb 13 '13 at 22:56

This article might be useful for Windows 8: How To Change Default Email Client In Windows 8.

Or in Chrome you could try the extension Send from Gmail (by Google).

[EDIT]

This can also be a site handler request coming from the gmail website itself, meaning Google trying (as always) to set itself up as unique web-services provider.

From the article Allow sites to open special types of links (handler) :

  • Click the Chrome menu Chrome menu on the browser toolbar.
  • Select Settings > Show advanced settings.
  • In the "Privacy" section, click Content settings.
  • In the dialog that appears, find the “Handlers” section:
    • To allow requests, select "Allow sites to ask to become default handlers for protocols".
    • To disable requests, select "Do not allow any site to handle protocols".

Try "Do not allow any site to handle protocols" to disable this dialog.

[EDIT2]

To get rid of the troublesome "Send from Gmail" extension, here are some alternative extensions:
Send using Gmail™ (no button)
Mailto: for Gmail

More articles :
mailto - use gmail in chrome
Make Gmail the Default Application for mailto Links in Google Chrome

share|improve this answer
    
I have already attempted to change the default mail client in the way linked here. Chrome is already listed as the default handler for mailto links. As you can see from the screenshot above, Win8 is asking if I want to "keep using Google Chrome" or switch to another application. What I don't understand is why it must keep asking. –  Ryan Feb 9 '13 at 15:39
    
I have added another possibility. –  harrymc Feb 11 '13 at 8:43
    
I've tried removing Chrome as a handler in this way, but still no luck. The popup returns if I'm using the extension. –  Ryan Feb 14 '13 at 23:13
    
I understand that my above addition does solve the problem, but that some extension is still force-allowing sites to ask for handlers. Which extension is it and do you have to keep it ? –  harrymc Feb 15 '13 at 6:42
    
If I don't have the "Send from Gmail" extension, I can't use Gmail as the default handler for mailto links. I still want that behavior, without Gmail asking me every time I visit the site. –  Ryan Feb 18 '13 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.