Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use PuTTY to connect to a CentOS server, and I sometimes need to enter Romanian characters from the keyboard. I use Windows 7 on the client computer; I have the server locale set up as en_US.UTF-8, and PuTTY is also configured for UTF-8.

I do NOT have any issues entering characters "î" and "ă" from the keyboard, and I also wouldn't have any problems entering the legacy cedilla characters "ş" (U+015F) and "ţ" (U+0163).

However, I can't enter the proper (comma) counterparts of the cedilla legacy characters "ș" (U+0219) and "ț" (U+021B). Whenever I try to use these two from the keyboard I get a question mark in the console. The issue is not related to the font I'm using in PuTTY, because I can copy/paste them (e.g. from this post), and I can generate them on the Linux host, e.g. by using

$ perl -Mcharnames=:full -CS -wle 'print "\N{LATIN SMALL LETTER S WITH COMMA BELOW}"'

I use Microsoft's stock keyboard settings for Romanian -- both "Romanian (Standard)" and "Romanian (Programmers)" produce the same results; "Romanian (Legacy)" works properly, but produces the legacy cedilla variants, which I'd rather not use.

How do I fix this?

share|improve this question
1  
Are you perhaps using screen? If so you also need to configure screen to use UTF-8 –  Tuim Jan 3 '13 at 13:03
    
Nope, just plain stock bash. –  Gutza Jan 3 '13 at 13:16
    
In my environment LANG=en_US.UTF-8 not LOCALE, but I don't know if that makes a difference for you. –  mhitza Jan 3 '13 at 14:46
    
Yep, same here, I just didn't want to list all output from locale. –  Gutza Jan 3 '13 at 15:13
add comment

migrated from stackoverflow.com Jan 3 '13 at 15:43

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 1 down vote accepted

After a long history* this bug has been fixed in release 0.63 http://www.chiark.greenend.org.uk/~sgtatham/putty/wishlist//win-tounicodeex.html


share|improve this answer
    
Oh, if it's a bug in putty then it's a bug in putty, and that's that. I thought I was doing something wrong (I thought I just had to fiddle with some locale settings somewhere). –  Gutza Jul 13 '13 at 13:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.