Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a Lenovo Ideapad Y580 with Windows 8 and I want to install Windows 7 on it.
I followed the instructions on this link to create a UEFI Windows 7 Install USB flash drive - but it does not work.

I followed the steps:

  1. Format my 4 GB USB flash drive to FAT32
  2. Copy the Windows 7 64 SP1 ISO contents to the flash drive
  3. copy /efi/microsoft/boot to /efi/boot
  4. find the bootmgfw.egi in install.wim, copy to the newly copied /efi/boot and rename it to bootx64.efi
  5. restart, enter the boot menu and select USB flash drive in the UEFI boot menu list

But after I select the USB drive and the initial loading windows progress bar finished, it hangs at the "Starting Windows" screen.

Is there something wrong with my steps?

share|improve this question
    
I heard that Windows7 USB/DVD Download Tool format the primary partition on usb to ntfs not fat32, so it may not work with UEFI, is that true? –  Ryan Jan 3 '13 at 20:02
    
Tried the Windows 7 Download Tool. The UEFI mode can not find the device, because Windows 7 Download Tool format the flash drive to NTFS. –  Ryan Jan 4 '13 at 2:51
    
I tried win8 iso with fat32 usb flash drive, it has no problem. But I can not get win7 work through, as I described in this post. –  Ryan Jan 4 '13 at 6:00

protected by Community Mar 8 '13 at 6:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.