Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Scenario

I run Windows 7 x64 and Titan FTP Server in both Active and Passive mode to share and synchronize data with my laptop and tablet.

Problem

I have to disable Windows Firewall or otherwise FTP clients won't be able to connect to PASV port. With firewall disabled everything works

Diagnosis

Thanks to Sysinternals's TCPView I found that the process listening on port 21 (expecting to listen on new passive ports) is srxTitan.exe

I could open Windows Firewall with Advanced Security and allow all incoming connections to that process, but... In C:\Program Files\South River Technologies\Titan FTP Server I can only find the following files

  • srxAdmin.exe
  • srxCFG.exe
  • srxTray.exe

I can't find srxTitan.exe anywhere

The question

Any advice on telling Windows Firewall that Titan FTP Server is cleared to accept incoming TCP connection on any port?

share|improve this question
up vote 1 down vote accepted

I'm a support engineer at South River Technologies. I found several articles via google that describe how to setup the windows firewall to allow passive FTP. For example, http://www.hosting.com/support/windows-server-2008/allow-passive-ftp-access-through-windows-firewall. Also, srxTitan.exe can be found in C:\windows\system32. In Titan, you can also limit the passive ports Titan will use - so that you don't have to open everything over 1024.

share|improve this answer
    
+1 for being "official" support. Enabling srxTitan.exe from system32 worked, but the article you linked fails on Windows 7. At least it was my 5-min-ago experience. Again, setting a rule for srxTitan.exe fixes the problem. Thank you – usr-local-ΕΨΗΕΛΩΝ Feb 16 '13 at 16:59
    
The link no longer works - you can access it via Wayback machine at: web.archive.org/web/20130525093606/http://www.hosting.com/… – Micah Aug 29 '14 at 21:32

The best way to test if your server is accepting connections on any ports is to host a file with it and attempt to access it from a client on your network. I know this is a simple answer but it's a simple solution. Usually when troubleshooting PASV mode, you can at least tell that the connection is being made and then failing when switching to PASV.

share|improve this answer
    
Unfortunately that's exactly what I was trying to do. I didn't mention in my question that client request came from LAN (I wouldn't ever use unencrypted FTP on WAN). With Wireshark I realized that the connection to the correct address and port was not established (but attempted by client) – usr-local-ΕΨΗΕΛΩΝ Jan 10 '13 at 8:40

I realize this is sometime after your question was asked, however I can upon this question while attempting to resolve this issue on a new Web server I was configuring.

The link that @Jeff posted,led me in the right direction and I found rules already configured for IIS's FTP Service. I disabled those rules and created the following rules to access the server using FTP, FTPS and SFTP:

FTP  - 20T  - Allow Port  20 using TCP 
FTP  - 21T  - Allow Port  21 using TCP 
FTP  - 21U  - Allow Port  21 using UDP 
FTPS - 989T - Allow port 989 using TCP
FTPS - 990T - Allow port 990 using TCP
FTPS - 990U - Allow port 990 using UDP
SFTP - 22T  - Allow port  22 using TCP

Here's the key:

FTP - 1024-65535T - Allow passive connections using TCP

I also specified a specific program for all the rules:

%SystemRoot%\System32\srxTitan.exe

It looks like they placed srxTitan.exe in the System32 folder.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .