Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My HP Media center harddrive crashed. I was told I could buy a new harddrive and reload from recovery disks copied off the system when I orignially bought the machine. My brother-in-law is trying to run the recovery and it stops towards the end. Message says "Windows Setup could not configure Windows to run on this computer's hardware". Any suggestions?? It is windows Vista.

It is a WD 1TB drive

It is a HP M9340f Media Center

share|improve this question
    
It is a WD 1TB drive –  Sona Jan 4 '13 at 4:19
    
It is a HP M9340f Media Center. –  Sona Jan 4 '13 at 4:20
    
2Tb is the largest physical drive Vista can handle so 1Tb should be fine... –  BobT Jan 4 '13 at 4:38
1  
See this Dell web page. More general information is here. Changing the BIOS settings for AHCI/IDE mode might help too. –  David Schwartz Jan 4 '13 at 5:35
    
@BobT: "2Tb is the largest physical drive Vista can handle" - Unless of course you install it on a UEFI + GPT machine. –  Karan Jan 5 '13 at 22:40
add comment

2 Answers

You may need to use the same hard drive model as your dead one. Unless you've tried the recovery, some recovery software is not as flexible such as using a different model or size hard drive. I use acronis easy image and that one is better about copying a hard drive to a different hard drive.

share|improve this answer
add comment

What size is your new hard drive?

HP's recovery instructions here state that you need to disconnect all external devices before trying to recover.

"With the computer off, disconnect all connected devices and cables such as the Personal Media Drive, USB drives, printer, and fax. Remove media from drives, and remove any recently added internal hardware. Do not disconnect the monitor, keyboard, mouse, and power cord."

If you haven't done this then that may be the source of your problem... I think the intent is to return the computer to the hardware state it was in when you created the recovery media. You might also check here for troubleshooting system recovery problems on your particular system.

share|improve this answer
    
It is a 1TB drive. Everything is disconnected. –  Sona Jan 4 '13 at 4:32
    
Thanks Guys! Got it. It was trying to read it as a RAID (so had to change the bios) and then it loaded fine. Thanks!! –  Sona Jan 5 '13 at 16:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.