Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have spent the past few weeks trying to resolve this problem and all attempts thus far have proved fruitless.

I have attempted all of the commonly-suggested things to do which include:

  • Formatting the HDD (I receive an error message, sometimes an I/O error message)
  • Creating a new partition (this works, but I am unable to save anything onto the HDD. I have tried creating both small (5GB) and large (931GB / maximum capacity) partitions, and although both are successfully created, they are useless)
  • Analysing the disk using testdisk (further error messages)
  • Attempted recovering some files using Recuva (HDD was inaccessible - another error message)


I have had my 1TB portable (Passport) external HDD for just over one year. It has not been dropped, squashed, bumped, etc. - I have taken wonderful care of it as I do with all such items.

I am happy to lose everything on the HDD - I just want to get it back to a working / useable state once more and it appears that, thus far, nothing is working and I'm beginning to doubt that anything will.

I should also add that, once a partition(s) has / have been created, I am still unable to format the HDD.

Any suggestions would be greatly appreciated.

Many thanks.


I am wondering if removing the HDD from its enclosure - and either using it like I would an internal HDD or replacing the casing - could help matters as I have read that, in a few cases, the enclosure could be failing - any thoughts on this possibility?

share|improve this question
Are you able to run a SMART tool on it? – Dave Jan 4 '13 at 10:38
@Dave Rook - Please see my comment below. – SnookerFan Jan 4 '13 at 10:54
OK, based upon that I totally with Dennis; you need to buy a new hard drive. Expensive but thankfully you were OK to lose the data. You could consider a RAID external drive or NAS next time although this won't help if cost is an issue! – Dave Jan 4 '13 at 10:56
up vote 1 down vote accepted

There are only two possibilities:

  • Your hard drive has gone bad.

    Compared with other computer components, hard drives wear out wear out abnormally fast. It's not necessary to drop them or anything else. They just do.

  • Your USB controller is faulty.

    Generally, if this happens, you cannot access the HDD at all, but it is possible.

Unless you can access the drive's S.M.A.R.T. data via the USB controller, the only way to reliably find out which one it is would be to remove the HDD from its case. This is usually possible without seriously damaging the case.

Once removed, you could access the HDD directly using a SATA port in your computer (assuming it doesn't use a proprietary connection). Once you know if it's the controller or the drive itself, you could replace the faulty part.

You'd also have access to the drives S.M.A.R.T. data via the SATA port. Frankly, I'm expecting a large amount of reallocated sectors...

Of course, if the drive is still under warranty, just get in touch with WD. Opening the case would void the warranty.

share|improve this answer
I have performed an analysis of the drive with a tool - forgive me, but the name escapes me at present - which showed that there were problems in a couple of areas; from what I remember, I believe that those areas were 'reallocated sectors count' and 'current pending sector count'. They could have been different, but having looked at the list in your link, these were the two areas which jumped out at me. With regards to USB connection: the HDD has been tried on multiple computers, all with the same result so this would not be the issue in this case. – SnookerFan Jan 4 '13 at 10:51
It meant the controller that is inside the drive's casing, which can go bad as well. If you have an elevated reallocated sector count, it's the drive itself. You need a new one. – Dennis Jan 4 '13 at 10:53
I see; and that's what I was afraid of... – SnookerFan Jan 4 '13 at 10:56

I have one that did that too. In Disk Management, I right clicked on the partition and it allowed me to add a drive letter. Then after a reboot, I could access the data once again. Have had that happen on several drives this last week or so. Not sure what is causing it yet

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .