Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I type in 'localhost/path/to/file' and hit Alt+Enter to open it in a new tab, Chrome seems to change it to 'www.localhost.com/path/to/file', which obviously fails to resolve. Is there any way to change Chrome's behavior so as to open 'localhost/path/to/file' in a new tab?

share|improve this question
    
When you write file, can I assume you are including the extension? Can I also assume you are trying to use Chrome as a file browser instead of an internet browser? – Dave Jan 4 '13 at 12:34
    
Enter http://localhost, that'll work – slhck Jan 4 '13 at 12:35
    
@DaveRook, the OP is using "localhost" so chrome is still functioning as a web browser. – terdon Jan 4 '13 at 12:36
    
@Dave: Of course, 'localhost/Events/event.php?name=Flawless' is what I'm really typing out. As you can see, I'm using it as an internet browser, not a file browser. – peteykun Jan 4 '13 at 12:36
1  
Well the quick and dirty hack would be to add localhost.com 127.0.0.1 to your Windows\System32\drivers\etc\hosts file and reboot... – Xyon Jan 4 '13 at 12:50

In Chrome, click:

Tools - Options- Under the hood - Change Proxy setting and then click on LAN Setting

Check "Bypass proxy server for local address"

share|improve this answer
    
I'm not using a proxy. – peteykun Jan 4 '13 at 16:58
up vote 0 down vote accepted

This now seems to be the new default behavior in Chrome.

Tested on Chrome Version 29.0.1547.65 (Xubuntu 13.04).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .