Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm attempting to RDP from the internet to a server in my LAN. Below is my setup (router is a Linksys E1200):

  • I am using dynamic DNS and I can ping my host name to my public IP address (let's say myhostname.com).

  • In my router I have configured port forwarding to forward external port 3389 to internal port 3389 to the IP address of the LAN server.

  • I have temporary disabled the firewall on the LAN server just to rule that local security out.

  • I have contacted my ISP and they ensured me that my modem was in full bridge mode and isn't blocking any port (including 3389).

  • I have set my router to not filter anonymous requests from the internet.

  • I have turned on logging on my router, but it seems like by default it only retains about 50 entries, and no timestamp so it's close to impossible to see if a request is coming in.

  • When I go to canyouseeme.org and put in port 3389 it's saying that it's blocked and the connection timed out.

What could I be doing wrong here? Am I missing something? If the packets are getting through my modem, they should be hitting my router. I believe I have configured my router to forward that port to the server. And I can locally RDP to the server (not to mention firewall is turned off just to rule that out). I'm not sure what else could be preventing me from doing this. When I do a portqry against TCP 3389 on the public IP/hostname I get a result saying it's filtered.

Any ideas are much appreciated. Not quite sure how to further troubleshoot this one.

share|improve this question

migrated from serverfault.com Jan 4 '13 at 15:03

This question came from our site for professional system and network administrators.

    
I'm gonna go ahead and blame the E1200, because it's hard to go wrong doing that. Plug the server into the cable/dsl modem directly, and see if that doesn't yield better results. Also, anything in a home setting is off topic, so this will probably be closed pretty soon... –  HopelessN00b Jan 4 '13 at 14:49
    
What does your router say the WAN IP is? –  longneck Jan 4 '13 at 14:49
2  
@ThomasStringer 10.x is an internal IP address. –  Dan Jan 4 '13 at 15:01
    
@Dan I'm not sure why it's saying that. I tried to "renew" but it remained the same. Do you think that's why I'm having this issue? –  Thomas Stringer Jan 4 '13 at 15:05

3 Answers 3

up vote 2 down vote accepted

Can I confirm for a moment what Longneck seems to be discovering and that your Cisco, Linksys box has an EXTERNAL IP address in the Class A 10.0.0.0 network ?

What is your internal IP, and HAVE YOU EVER SUCCESSFULLY REMOTELY CONNECTED TO ANYTHING INSIDE YOUR INTERNAL NETWORK ?

Because..... if your routers external IP is that class A ten, then YEAH, youre being filtered beyond that router and I'd be loathe to rely on anything told to me by an ISP tech support staffer since if they knew what they were talking about, they wouldn't be answering your tech support questions but working in the back and dealing only with commercial clients and their networking engineers.

Your DYNDNS client could still be working and giving the false impression of your web presence since the DynDNS software agents or just the basic transaction is an outbound HTTP transaction that is designed to burrow out to the DNS servers and will report whatever external IP address it managed to exfiltrate out of, it is reliable but it shouldn't be relied upon to confirm remote access. Its for that same reason DYNDNS won't choke or object to the fact it is being hosted on a private internal network.

share|improve this answer

It's not working because there is another router in front of your router doing NAT. The IP address of 10.0.0.5 would typically only be assigned by a router running NAT.

share|improve this answer

You can use a traffic sniffer on your LAN Server to see if there are some packages coming from the router at the port 3389.

You said that the router does not filter anonymous requests from the internet. Might there be any other restriction on the router like a firewall blocking some ports?

share|improve this answer
    
I've disabled the IPv4 and IPv6 firewall settings on the router. –  Thomas Stringer Jan 4 '13 at 14:58
    
What about sniffing the traffic? –  lukassteiner Jan 4 '13 at 15:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.