Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


Because of my somewhat excessive use of tabs—which often contain PDFs'—I use 64-bit builds of Firefox. It has now gotten to a point where I want to use different profiles; one for my research the other for my day-to-day stuff.


  1. Created a new profile called: Research, by running Firefox with the -P CLI arg.
  2. Quit Firefox
  3. Created two shortcuts following the official documentation; linked to:
    • [path to firefox]\firefox.exe -no-remote -P "Research"
    • [path to firefox]\firefox.exe -no-remote -P "default"
  4. Opened each shortcut


Only the fast profile clicked loaded; opening the second shortcut just opens a new Window in the previous profile. Same happens if I open them with inverse order.


I tried linking the shortcuts to different Firefox binaries (i.e.: HTguard, Waterfox, Cyberfox) to no avail.

How do I get multiple profiles to work side-by-side; on Windows 8?

share|improve this question
What about creating a script just with "[path to firefox]\firefox.exe -no-remote" and then lanching the script with the "run as..." option to choose the user/profile? – jap1968 Jan 4 '13 at 16:46
More streamlined + efficient to just use these shortcuts. – A T Jan 4 '13 at 16:47
I agree, this is to point a different alternative just to see if this way you achieve to get the application running as you want. – jap1968 Jan 4 '13 at 16:51
Just a comment that MozillaZine is written by user volunteers; it's not official. – Wk_of_Angmar Jan 4 '13 at 23:42
The above should have worked. Did you make sure that you made no typos/correct profile name (capitals)? – Wk_of_Angmar Jan 4 '13 at 23:43

You do not need to install multiple versions of Firefox to do this. If you want to have two shortcuts, one which launches the default profile and one which launches a profile named "Research", your two shortcuts should point to:

  • [path to firefox]\firefox.exe
  • [path to firefox]\firefox.exe -P Research -no-remote

It does not matter which shortcut you launch first.

Opening a new instance of your Mozilla application with another profile:

Never use -no-remote to start the "default" profile (the one that is set to open without asking when you launch Firefox). That's because when you launch Firefox, for example, by clicking a link in your mail program, you will get a "Firefox is already running but is not responding" message if the default profile is already in use. The solution is to always start the default profile normally and launch all others with -no-remote. Then it will work.

share|improve this answer
Not really a solution to the actual issue, since manually opening two different profiles with -no-remote should still work. – Wk_of_Angmar Jan 4 '13 at 23:46
@Wk_of_Angmar The knowledge base I quoted clearly states that the -no-remote flag should not be used with the default profile. One of your shortcuts should use -P research -no-remote and the other shortcut should have no arguments and will open with the default profile. – William Jackson Jan 14 '13 at 2:44
Yes that is correct, but it still should have worked for OP. The only problem with setting -no-remote with the default profile is that you cannot open a new instance of it (and thus hyperlinks from other programs and reopening the program will not work). But it should still open an instance the first time instead of opening a new window on the current instance. – Wk_of_Angmar Jan 14 '13 at 22:34

Okay, got it to work with a mix of HTguard and Cyberfox.

I must of only tried the HTguard+HTguard, Cyberfox+Cyberfox, Waterfox+Waterfox, HTguard+Waterfox, Cyberfox+Waterfox combinations before; missing the HTguard+Cyberfox combination.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .