Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am downloading thousands of files over FTP using Filezilla. The download takes several hours, so I want to run it overnight, but there is a problem - Filezilla keeps re-asking the password every now and then - almost like every 10 minutes! Why? How to fix this?

I've enabled FileZilla to establish 2 simultaneous FTP connections. It is strange that FileZilla keeps re-asking for password, even if I have set Logontype to "Ask for password". Snip from the documentation:

Ask for password: FileZilla asks you the password during logon, and it remembers the password during the session.

Interactive: FileZilla asks for the password, and asks again for every new connection to the server.

This means that when I set "Ask for password", it shouldn't ask for every new connection to the server. Yet it does ask again and again...

Site manager settings:

enter image description here enter image description here enter image description here

Login settings:

enter image description here

Settings:

enter image description here enter image description here enter image description here enter image description here enter image description here

The log just after Filezilla re-asks the password (with 1 simultaneous connection only the log looks exactly the same):

Command:    PASV
Response:   227 Entering Passive Mode (81,31,47,235,239,66).
Command:    RETR P034624.jpg
Response:   150 Opening BINARY mode data connection for P034624.jpg (1242518 bytes)
Response:   226 Transfer complete
Status: File transfer successful, transferred 1 242 518 bytes in 1 second
Status: Starting download of /avif/photos/orig/P034625.jpg
Command:    PASV
Error:  GnuTLS error -53 in gnutls_record_send: Error in the push function.
Error:  Could not write to socket: ECONNABORTED - Connection aborted
Error:  Disconnected from server
Error:  File transfer failed
Status: Resolving address of ftp.birds.cz
Status: Connecting to 81.31.47.235:21...
Status: Connection established, waiting for welcome message...
Response:   220 iris.fortion.net
Command:    AUTH TLS
Response:   234 AUTH TLS successful
Status: Initializing TLS...
Status: Verifying certificate...
Command:    USER birds.cz
Status: TLS/SSL connection established.
Response:   331 Password required for birds.cz
Command:    PASS 
Response:   530 Login incorrect.
Error:  Critical error
Error:  Could not connect to server

Screenshot of the log right after Filezilla re-asks the password:

enter image description here

If I switch to Active mode, the download works without re-asking the password!!! (Tested with 1 simultaneous connection and Timeout = 0).

But, delete doesn't work - it will break the connection after like 400 deleted files in both active and passive mode, 1 sim. connection, timeout 0. This time it doesn't re-ask the password, it just stops. The log:

Command:    DELE P025791.jpg
Response:   250 DELE command successful
Command:    DELE P025792.jpg
Response:   250 DELE command successful
Command:    DELE P025793.jpg
Error:  GnuTLS error -53 in gnutls_record_send: Error in the push function.
Error:  Could not write to socket: ECONNABORTED - Connection aborted
Error:  Disconnected from server

Conclusion

The above testing was done from my office, Windows 7, behind Zyxel P660HW-T3 FW/modem with more or less default settings. Switching to passive mode has helped here for downloading, for deleting no remedy found. When I tried from home, Windows XP, Filezilla 3.7.3 (current), behind Edimax BR6225N/BR6226N FW/modem, it both downloading and deleting went all OK even with default settings (timeout = 20, 2 sim. connections, passive mode)!!!

Edit: now I tried to delete the files from home, it was OK, then moved with my laptop to office (without closing Filezilla) and suddenly it was also OK! But yesterday from office the deletion stopped after almost 400 files. Interesting! Maybe it depends where I log in first?

share|improve this question
    
Have you had any issues with intermittent connectivity? –  Michael H Oct 11 '13 at 15:28
    
Nope. And it is tested well from different places (ssh connections working fine etc.). –  Tomas Oct 11 '13 at 15:35

3 Answers 3

Interesting. I've never had Filezilla ever re-ask me for a password during a transfer process.

Have you tried to set the Timeout to 0 so that it doesn't close the connection if there is a timeout with server? I would try that and see if that works or not.

Also, what kind of server is it that you are trying to connect into? Is it Windows or Linux?

You might have switch it from Passive to Active mode:

enter image description here

I know I had to do that recently with FTP'ing into a client server.

What I normally do when connecting to a server is use the Quickconnect in the top area:

enter image description here

If I want to save that info, then I copy the connection to the site manager:

enter image description here

If I need to open another connection, then I usually create a new tab and do the process over again.

It also could be a server configuration as well. It might be that the server is configured to only leave any FTP connections open for a limited amount of time.

Another issue could be bandwidth and connection to the server. I might be possible that the connection is timing out and disconnecting, and then on re-connect it needs the password again.

But try setting the Timeout to 0 and see if that works or not.

I'd also recommend looking at your firewall settings as well. From the looks of the log records, it might be from a firewall setting somewhere:

https://forum.filezilla-project.org/viewtopic.php?t=14574

share|improve this answer
    
tried to set timeout to 0, but the result is the same. I've updated the question with the log. –  Tomas Oct 11 '13 at 16:39
1  
Have you tried to force it to Active mode instead of Passive? –  ultraloveninja Oct 11 '13 at 16:45
    
This works!! But, only for file download. If I try to delete those thousands files on the server, the connection will break after each cca 400 files. Please see the updated question. –  Tomas Oct 11 '13 at 18:48
    
Sweet! I'm glad you are able to download! As far as the deleting goes, that might be a whole other issue. There may not be the correct permissions set for the modification or removal of files. That would be my guess. If you connect back in again, do you see that the files are gone? –  ultraloveninja Oct 11 '13 at 19:06
    
Yes, I do. Resetting of connection has nothing to do with file permissions - the cca 400 files are deleted successfully. –  Tomas Oct 11 '13 at 19:08

I had the same problem – it asked for password at each download.

I fixed the issue in Edit » Settings » Transfer » File type. Set it to Binary (it was previously on Auto)

share|improve this answer

I fixed this by going to

Edit > Settings > Interface > Behaviour > "Do not save passwords" [uncheck box]

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.